matplotlib and numpy incompatible

I am having running pylab from scipy in that I get the error messsage
“”" E:\ProgramFiles\Python\Lib\site-packages\matplotlib_contour.py", line 17, in ?

 from matplotlib._ns_cntr import *

RuntimeError: module compiled against version 90709 of C-API but this version of numpy is 1000000"""

I am using the following modules
python 2.4 scipy-0.5.0
python 2.4 numpy-1.0b1
python 2.4 matplotlib-087.4

and running python windowsXp
I cant find other versions of matlinbplot, and when I try different versions of numpy I get an error of the sort that
it cant load oldnumeric.

Can someone suggest a solution to my problem

thanks

george gumas

George,

I am not a Windows user, so I can't report from my own experience, but here are some things to try:

1) Enthought Python suite: http://code.enthought.com/enthon/
The matplotlib version is slightly behind (0.87.3), but that may not matter for your present purposes.

2) Wait until a new matplotlib release compatible with current numpy is made. It has been under discussion, so I think it will be soon.

3) Until (2) occurs, use numarray or Numeric instead of numpy. They have been stable for a long time. I assume the Windows mpl compilation supports them.

4) Did you try http://prdownloads.sourceforge.net/numpy/numpy-0.9.8.win32-py2.4.exe?download

I think that is this the version that matches the Windows mpl 0.87.4, but if you really need scipy, then I think you would have to back up to an earlier version of that.

Eric

George Gumas wrote:

···

I am having running pylab from scipy in that I get the error messsage
""" E:\ProgramFiles\Python\Lib\site-packages\matplotlib\_contour.py", line 17, in ?
     from matplotlib._ns_cntr import *
    RuntimeError: module compiled against version 90709 of C-API but this version of numpy is 1000000"""

I am using the following modules
python 2.4 scipy-0.5.0
python 2.4 numpy-1.0b1
python 2.4 matplotlib-087.4

and running python windowsXp
I cant find other versions of matlinbplot, and when I try different versions of numpy I get an error of the sort that
it cant load oldnumeric.
  Can someone suggest a solution to my problem

thanks

george gumas

------------------------------------------------------------------------

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

------------------------------------------------------------------------

_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

George,

I have had the same problem and
I did like Erics number one suggestion and it worked for me

Tommy

Eric Firing skrev:

···

George,

I am not a Windows user, so I can't report from my own experience, but here are some things to try:

1) Enthought Python suite: http://code.enthought.com/enthon/
The matplotlib version is slightly behind (0.87.3), but that may not matter for your present purposes.

2) Wait until a new matplotlib release compatible with current numpy is made. It has been under discussion, so I think it will be soon.

3) Until (2) occurs, use numarray or Numeric instead of numpy. They have been stable for a long time. I assume the Windows mpl compilation supports them.

4) Did you try http://prdownloads.sourceforge.net/numpy/numpy-0.9.8.win32-py2.4.exe?download

I think that is this the version that matches the Windows mpl 0.87.4, but if you really need scipy, then I think you would have to back up to an earlier version of that.

Eric

George Gumas wrote:
  

I am having running pylab from scipy in that I get the error messsage
""" E:\ProgramFiles\Python\Lib\site-packages\matplotlib\_contour.py", line 17, in ?
     from matplotlib._ns_cntr import *
    RuntimeError: module compiled against version 90709 of C-API but this version of numpy is 1000000"""

I am using the following modules
python 2.4 scipy-0.5.0
python 2.4 numpy-1.0b1
python 2.4 matplotlib-087.4

and running python windowsXp
I cant find other versions of matlinbplot, and when I try different versions of numpy I get an error of the sort that
it cant load oldnumeric.
  Can someone suggest a solution to my problem

thanks

george gumas

------------------------------------------------------------------------

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

------------------------------------------------------------------------

_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users
    
-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

--
Tommy Johansson
Adapteam Consulting AB
Skårs Led 3
412 63 Göteborg
Sweden
www.adapteam .se

Tel Sweden: +46 31 7037128
Mob Sweden: +46 768 889311
Fax Sweden: +46 768 710932
Mob Jakarta: +62 81 382 282 940
tommy.johansson@...1216...