matplotlib 0.91.2 build failure

Dear all,

I am building the 0.91.2 version on a Fedora 9. I have compiled this
version on Fedora 8 earlier with no problem. However, this time the
package failed to build.

Here is the last lines from the output:

gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fPIC
-I/usr/local/include -I/usr/include -I. -I/usr/include/python2.5 -c
ttconv/pprdrv_tt2.cpp -o build/temp.linux-i686-2.5/ttconv/pprdrv_tt2.o
In file included from ttconv/pprdrv_tt2.cpp:40:
ttconv/truetype.h:50: error: ISO C++ forbids declaration of 'FILE' with no type
ttconv/truetype.h:50: error: expected ';' before '*' token
error: command 'gcc' failed with exit status 1

The compilers I use are gcc 4.3.0 (with g++).
Is there anything broken, or I'm missing something?

Thanks in advance.

Cong.

The compiler that ships with Fedora 9 is a little more strict about C header file usage from a C++ file. This was fixed in matplotlib SVN less than two weeks ago.

You can either

a) checkout the maintenance branch from SVN, which is basically like 0.91.2 but with a number of small bugfixes, including this one:

    svn co https://matplotlib.svn.sf.net/svnroot/matplotlib/branches/v0_91_maint matplotlib-0.91.x

b) manually apply this diff to your 0.91.2 copy:

   http://matplotlib.svn.sourceforge.net/viewvc/matplotlib?view=rev&revision=5128

I'd recommend a) if you're comfortable with subversion.

Cheers,
Mike

···

frigoris.ma@...287... wrote:

Dear all,

I am building the 0.91.2 version on a Fedora 9. I have compiled this
version on Fedora 8 earlier with no problem. However, this time the
package failed to build.

Here is the last lines from the output:

gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fPIC
-I/usr/local/include -I/usr/include -I. -I/usr/include/python2.5 -c
ttconv/pprdrv_tt2.cpp -o build/temp.linux-i686-2.5/ttconv/pprdrv_tt2.o
In file included from ttconv/pprdrv_tt2.cpp:40:
ttconv/truetype.h:50: error: ISO C++ forbids declaration of 'FILE' with no type
ttconv/truetype.h:50: error: expected ';' before '*' token
error: command 'gcc' failed with exit status 1

The compilers I use are gcc 4.3.0 (with g++).
Is there anything broken, or I'm missing something?

Thanks in advance.

Cong.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft Defy all challenges. Microsoft(R) Visual Studio 2008. http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users
  
--
Michael Droettboom
Science Software Branch
Operations and Engineering Division
Space Telescope Science Institute
Operated by AURA for NASA

Thanks for the information. The svn version built seamlessly.

···

On Tue, May 20, 2008 at 8:34 PM, Michael Droettboom <mdroe@...86...> wrote:

The compiler that ships with Fedora 9 is a little more strict about C header
file usage from a C++ file. This was fixed in matplotlib SVN less than two
weeks ago.

You can either

a) checkout the maintenance branch from SVN, which is basically like 0.91.2
but with a number of small bugfixes, including this one:

  svn co
https://matplotlib.svn.sf.net/svnroot/matplotlib/branches/v0_91_maint
matplotlib-0.91.x

b) manually apply this diff to your 0.91.2 copy:

http://matplotlib.svn.sourceforge.net/viewvc/matplotlib?view=rev&revision=5128

I'd recommend a) if you're comfortable with subversion.

Cheers,
Mike

frigoris.ma@...287... wrote:

Dear all,

I am building the 0.91.2 version on a Fedora 9. I have compiled this
version on Fedora 8 earlier with no problem. However, this time the
package failed to build.

Here is the last lines from the output:

gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fPIC
-I/usr/local/include -I/usr/include -I. -I/usr/include/python2.5 -c
ttconv/pprdrv_tt2.cpp -o build/temp.linux-i686-2.5/ttconv/pprdrv_tt2.o
In file included from ttconv/pprdrv_tt2.cpp:40:
ttconv/truetype.h:50: error: ISO C++ forbids declaration of 'FILE' with no
type
ttconv/truetype.h:50: error: expected ';' before '*' token
error: command 'gcc' failed with exit status 1

The compilers I use are gcc 4.3.0 (with g++).
Is there anything broken, or I'm missing something?

Thanks in advance.

Cong.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft Defy all challenges.
Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

--
Michael Droettboom
Science Software Branch
Operations and Engineering Division
Space Telescope Science Institute
Operated by AURA for NASA