matplotlib-0.54 Win98 crash

Hi John,
I probably didn't make it clear, but TkAgg has problems too.
Here's what I know:
Under 0.53.1 TkAgg and GTKAgg both worked fine, both when running the script directly from Windows Explorer in which case file association cause python to fire up in a DOS shell, and when running it from within SciTE or IDLE things are fine too. 0.54 has changed something. I tried grabbing and running a few examples from CVS as well as my own previously working examples. They behave consistently - GTKAgg no longer works at all and TkAgg works but only if I run it from DOS with a -dTkAgg option.
It may be a GUI conflict but it has only started to conflict with 0.54.
removing show() or replacing it with show(mainloop=False) seem to make no difference to the behaviour running TkAgg from SciTE.
I do notice that the python >>> prompt comes up in any DOS windows when running with the -dTkAgg option after the Tk plot window displays. Closing the window then leaves the python prompt and I have to ^Z it to shut it down. It's like it thinks it should be running in interactive mode, although 'interactive : False' is set in my .matplotlibrc
This seems abnormal to me.

In my original post I asked if anyone else had success or problems in Win98 and since noone replied, maybe we can assume that I'm one of the rare users who's still using it. Therefore, as much as I (and probably you) would like to get to the bottom of what's happening, it's probably Win98 specific and therefore, can probably wait; at least until after my upcoming exams are over and I get a chance to really look into it some more. So I might go quiet for a few weeks unless you want me to try anything quick and specific.
Finally, I hope you didn't lose the ecolor changes I made to errorbars and they might make it into a future version :slight_smile:



Sign-up for Ads Free at