[Mac OS 10.4.10, Python 2.5] LineCollection error

Hi! I have some code importing MPL and wxmpl; presently, I have version 0.90.1 of the former installed and 1.2.8 of the latter. I hadn't run this code in a while; when I last did, in the late spring sometime, it worked fine. Now, when I do (from the command line), a call in it to <class-derived-from-wxmpl.PlotPanel>.Axes.clear() results in an error seq. ending in AttributeError: VectorLineCollection instance has no attribute 'get_xdata'. One "catch": the "old" version still exists as a py2app-ed stand-alone; I tried it and sure enough, it still works fine. By searching its Mac App file tree, I was able to determine that this old py2app-ed version is using version 0.90.0 of MPL; unfortunately, it (appears to be) using a compiled version of wxmpl, so I don't know how to determine what version of that its using. Did the update of MPL from 0.90.0 to 0.90.1 change anything that might result in this error; has there been a change in wxmpl which might result in this error? (Between then and now, I switched to a new Mac and installed everything from scratch, so it's very likely that my present version of wxmpl is different from the one I had installed when I created the py2app.) Any other ideas? (I'm at a total loss.) Thanks!

DG
--
ERD/ORR/NOS/NOAA <http://response.restoration.noaa.gov/emergencyresponse/&gt;

Additional info: when I'm in the directory in which wxmpl.pyc resides inside the py2app bundle, run Python and import wxmpl, I get:

Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "wxmpl.pyc", line 18, in <module>
   (
File "wx/__init__.pyc", line 45, in <module>
   File "wx/_core.pyc", line 4, in <module>
   File "wx/_core_.pyc", line 18, in <module>
   File "wx/_core_.pyc", line 15, in __load
  ImportError: '/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/lib-dynload/wx/_core_.so' not found

(Note that the application package from which I got this error is the version of the program that works!)

Following a suggestion, I copied this wxmpl.pyc to a place outside the application package, ran python, and it imported fine. I checked its version number and it's 1.2.8, same as what I have installed presently (wxmpl.__file__ verified that the local version was imported, not my site-packages version).

I'm at more of a loss than ever...

DG

ยทยทยท

--
ERD/ORR/NOS/NOAA <http://response.restoration.noaa.gov/emergencyresponse/&gt;