ipython, pylab quitting again after first time

Hello,

I have some trouble with ipython and matplotlib. I create a figure in one of my functions that I call from ipython. The first time it runs fine and I can use the figure interactively (selecting/ deselcting points and so on). The second time I run it, the code doesnt stop but continues without halting at the show routine.
I'm doing this on a Mac (10.5.2/ Intel). On my Linux machine I did pylab.get_current_figure_manager().destroy() and bound it to a key to prevent this. If I do this on the mac (WXAgg) The next time I want to plot it complains about a deleted C++ extension and doesnt plot at all.
Please help
    Wolfgang

Can you attach the traceback?

Cheers,
Mike

Wolfgang Kerzendorf wrote:

···

Hello,

I have some trouble with ipython and matplotlib. I create a figure in one of my functions that I call from ipython. The first time it runs fine and I can use the figure interactively (selecting/ deselcting points and so on). The second time I run it, the code doesnt stop but continues without halting at the show routine.
I'm doing this on a Mac (10.5.2/ Intel). On my Linux machine I did pylab.get_current_figure_manager().destroy() and bound it to a key to prevent this. If I do this on the mac (WXAgg) The next time I want to plot it complains about a deleted C++ extension and doesnt plot at all.
Please help
    Wolfgang

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users
  
--
Michael Droettboom
Science Software Branch
Operations and Engineering Division
Space Telescope Science Institute
Operated by AURA for NASA