installing matplotlib

Hi Reik,

FT_KERNING_DEFAULT is defined in freetype2/freetype/freetype.h.
If it's not there, you need to upgrade freetype2.

Nadia Dencheva

Date: Sun, 5 Dec 2004 16:51:48 +0100
From: "Reik H. Börger" <reikhboerger@...380...>
Subject: [Matplotlib-users] installing matplotlib
To: matplotlib-users@lists.sourceforge.net

Hi,

once again I try to install matplotlib on a new install of

MacOSX 10.3.

I think, I got all the required dependencies and when I start

the

installation of matplotlib via
python setup.py build
it starts working, but after some steps it terminates with:

src/ft2font.cpp: In member function 'void

FT2Font::load_glyphs()':

src/ft2font.cpp:376: error: 'FT_KERNING_DEFAULT' undeclared

(first use

this function)
src/ft2font.cpp:376: error: (Each undeclared identifier is

reported

only once for each funtion it appears in.)
error: command 'gcc' failed with exit status 1

What went wrong? Any suggestions? I am lost... :frowning:

Thanks
Reik

-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from

real users.

Discover which products truly live up to the hype. Start

reading now.

···

---- Original message ----

http://productguide.itmanagersjournal.com/
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users