Installing matplotlib dev version on ubuntu from source file

I did the following in order to (try) to install matplotlib :

$ git clone clone https://github.com/matplotlib/matplotlib.git
$ cd matplotlib
$ python setup.py build

Which generates the following message :

···

============================================================================
Edit setup.cfg to change the build options

BUILDING MATPLOTLIB
            matplotlib: yes [1.5.0+226.g2f3b2ca]
                python: yes [2.7.9 (default, Apr 2 2015, 15:33:21) [GCC
                        4.9.2]]
              platform: yes [linux2]

REQUIRED DEPENDENCIES AND EXTENSIONS
                 numpy: yes [version 1.8.2]
              dateutil: yes [using dateutil version 2.2]
           functools32: yes [functools32 was not found. It is required for
                        forpython versions prior to 3.2]
                  pytz: yes [using pytz version 2014.10]
                cycler: yes [cycler was not found. pip will attempt to
                        install it after matplotlib.]
               tornado: yes [tornado was not found. It is required for the
                        WebAgg backend. pip/easy_install may attempt to
                        install it after matplotlib.]
             pyparsing: yes [using pyparsing version 2.0.3]
                libagg: yes [pkg-config information for 'libagg' could not
                        be found. Using local copy.]
              freetype: no [The C/C++ header for freetype2 (ft2build.h)
                        could not be found. You may need to install the
                        development package.]
                   png: no [pkg-config information for 'libpng' could not
                        be found.]
                 qhull: yes [pkg-config information for 'qhull' could not be
                        found. Using local copy.]

OPTIONAL SUBPACKAGES
           sample_data: yes [installing]
              toolkits: yes [installing]
                 tests: yes [using nose version 1.3.4 / using mock 1.0.1]
        toolkits_tests: yes [using nose version 1.3.4 / using mock 1.0.1]

OPTIONAL BACKEND EXTENSIONS
                macosx: no [Mac OS-X only]
                qt5agg: no [PyQt5 not found]
                qt4agg: yes [installing, Qt: 4.8.6, PyQt: 4.8.6; PySide not
                        found]
               gtk3agg: yes [installing, version 3.13.14]
             gtk3cairo: yes [installing, version 3.13.14]
                gtkagg: no [The C/C++ header for gtk (gtk/gtk.h) could not
                        be found. You may need to install the development
                        package.]
                 tkagg: no [The C/C++ header for Tk (tk.h) could not be
                        found. You may need to install the development
                        package.]
                 wxagg: no [requires wxPython]
                   gtk: no [The C/C++ header for gtk (gtk/gtk.h) could not
                        be found. You may need to install the development
                        package.]
                   agg: yes [installing]
                 cairo: yes [installing, pycairo version 1.8.8]
             windowing: no [Microsoft Windows only]

OPTIONAL LATEX DEPENDENCIES
                dvipng: yes [version 1.14]
           ghostscript: yes [version 9.15]
                 latex: yes [version 3.14159265]
               pdftops: yes [version 0.30.0]

OPTIONAL PACKAGE DATA
                  dlls: no [skipping due to configuration]

============================================================================
                        * The following required packages can not be built:
                        * freetype, png

When I thereupon ran install command
$ python setup.py install

I got the same output as above. Nothing happend. I have got v.1.4.2 on my machine, but would really like to have the dev version to test the new colormaps.

Imran
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/matplotlib-users/attachments/20151104/5f586c63/attachment.html>

I forgot to mention, when I ran

$ sudo apt-get build-dep python-matplotlib

I got the following message : (translated from Norwegian)

Reding package lits ... Done
Creating overview for the dependencies
Reading status information ... Done
Choosing ?matplotlib? as source package instead of ?python-matplotlib?
Following packages have unresolved dependency relationships:
libgtk2.0-dev : Depends on: libglib2.0-dev (>= 2.27.3) but shall not be installed
                 Depends on: libgdk-pixbuf2.0-dev (>= 2.21.0) but shall not be installed
                 Depends on: libpango1.0-dev (>= 1.20) but shall not be installed
                 Depends on: libatk1.0-dev (>= 1.29.2) but shall not be installed
                 Depends on: libcairo2-dev (>= 1.6.4-6.1) but shall not be installed
python-gtk2-dev : Depends on: libglib2.0-dev (>= 2.8) but shall not be installed
                   Depends on: python-gobject-2-dev (>= 2.21.3) but shall not be installed
E: Did not manage to satisfy build dependencies for python-matplotlib.

4. nov. 2015 kl. 15.05 skrev Imran Ali <imranal at math.uio.no>:

I did the following in order to (try) to install matplotlib :

$ git clone clone https://github.com/matplotlib/matplotlib.git
$ cd matplotlib
$ python setup.py build

Which generates the following message :

============================================================================
Edit setup.cfg to change the build options

BUILDING MATPLOTLIB
            matplotlib: yes [1.5.0+226.g2f3b2ca]
                python: yes [2.7.9 (default, Apr 2 2015, 15:33:21) [GCC
                        4.9.2]]
              platform: yes [linux2]

REQUIRED DEPENDENCIES AND EXTENSIONS
                 numpy: yes [version 1.8.2]
              dateutil: yes [using dateutil version 2.2]
           functools32: yes [functools32 was not found. It is required for
                        forpython versions prior to 3.2]
                  pytz: yes [using pytz version 2014.10]
                cycler: yes [cycler was not found. pip will attempt to
                        install it after matplotlib.]
               tornado: yes [tornado was not found. It is required for the
                        WebAgg backend. pip/easy_install may attempt to
                        install it after matplotlib.]
             pyparsing: yes [using pyparsing version 2.0.3]
                libagg: yes [pkg-config information for 'libagg' could not
                        be found. Using local copy.]
              freetype: no [The C/C++ header for freetype2 (ft2build.h)
                        could not be found. You may need to install the
                        development package.]
                   png: no [pkg-config information for 'libpng' could not
                        be found.]
                 qhull: yes [pkg-config information for 'qhull' could not be
                        found. Using local copy.]

OPTIONAL SUBPACKAGES
           sample_data: yes [installing]
              toolkits: yes [installing]
                 tests: yes [using nose version 1.3.4 / using mock 1.0.1]
        toolkits_tests: yes [using nose version 1.3.4 / using mock 1.0.1]

OPTIONAL BACKEND EXTENSIONS
                macosx: no [Mac OS-X only]
                qt5agg: no [PyQt5 not found]
                qt4agg: yes [installing, Qt: 4.8.6, PyQt: 4.8.6; PySide not
                        found]
               gtk3agg: yes [installing, version 3.13.14]
             gtk3cairo: yes [installing, version 3.13.14]
                gtkagg: no [The C/C++ header for gtk (gtk/gtk.h) could not
                        be found. You may need to install the development
                        package.]
                 tkagg: no [The C/C++ header for Tk (tk.h) could not be
                        found. You may need to install the development
                        package.]
                 wxagg: no [requires wxPython]
                   gtk: no [The C/C++ header for gtk (gtk/gtk.h) could not
                        be found. You may need to install the development
                        package.]
                   agg: yes [installing]
                 cairo: yes [installing, pycairo version 1.8.8]
             windowing: no [Microsoft Windows only]

OPTIONAL LATEX DEPENDENCIES
                dvipng: yes [version 1.14]
           ghostscript: yes [version 9.15]
                 latex: yes [version 3.14159265]
               pdftops: yes [version 0.30.0]

OPTIONAL PACKAGE DATA
                  dlls: no [skipping due to configuration]

============================================================================
                        * The following required packages can not be built:
                        * freetype, png

When I thereupon ran install command
$ python setup.py install

I got the same output as above. Nothing happend. I have got v.1.4.2 on my machine, but would really like to have the dev version to test the new colormaps.

Imran

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/matplotlib-users/attachments/20151104/f0b2eefc/attachment-0001.html>

It looks like you need to install two development packages using your
linux distro package manager. If you are using ubuntu 14.04, for
example, it would be

sudo apt-get install libfreetype6-dev libpng12-dev

Eric

···

On 2015/11/04 4:05 AM, Imran Ali wrote:

/ freetype: no [The C/C++ header for freetype2 (ft2build.h)/
/ could not be found. You may need to install the/
/ development package.]/
/ png: no [pkg-config information for 'libpng' could not/
/ be found.]/