installed python-scipy causing errors with numpy


From: Eric Firing <efiring@…202…>
Sent: Saturday, February 18, 2012 12:26 PM
Subject: Re: [Matplotlib-users] installed python-scipy causing errors with numpy

On 02/18/2012 07:17 AM, Michael Rawlins wrote:

A couple weeks ago I installed version 1.2 from sources, as described here:

I’m running Ubuntu 10.04 LTS. Everything was working fine. Looks like
numpy version 1.3 in place. A few minutes ago I installed python-scipy
from the Ubuntu Synaptic package manager. Getting this any time I run a

Traceback (most recent call last):
File “”, line 5, in
from matplotlib import pyplot, mpl
File “/usr/local/lib/python2.6/dist-packages/matplotlib/”,
line 173, in
version__numpy, numpy.version))
ImportError: numpy 1.4 or later is required; you have

Version control with python, matplotlib, numpy, etc problematic when
compiled from source? Shall I reinstall everything again, including
python-scipy? What order? Thanks.

You need to remove your numpy and scipy packages and install both of
these from source (just use the most recent releases), and then rebuild
matplotlib. Numpy has to be installed before building either scipy or
mpl, but mpl and scipy are independent of each other so either can be
built once a suitable numpy is there.


I did not mention that I already had python 2.6 installed when I