Installation problem

Hi Domenico,

Yes, the problem was resolved and it all works great now. I can't
tell you exactly what fixed it because I am no an expert on library
files, compiling stuff, etc. However, here is what I thought: I
thought that the libstdc++.so was not finding the correct library
files for the compiler or that there was a difference between the
version of gcc compiler used to make the libstdc++.so file and the gcc
compiler that I used to build other python related dependencies like
numpy. So here is what I did: (I'm sorry but I do not know how to do
this in wondows. I only know what I did linux)

1) Installed a brand new version on the gcc suite of compilers on my
computer. (I took a long time to do this, but I wanted to make sure
that all the library files and the compilers that I used matched up
and worked well.) I seem to recall that there was one flag which was
important: I think it was --with-gnu-ld, which tells gcc to use the
gnu ld program for linking library files. Please also be sure to set
the LD_LIBRARY_PATH variable to find all the appropriate library
files.

2) I rebuilt LAPACK and ATLAS (because I was having trouble with them
too and I knew that numpy depended on the lapack routines.

3) I rebuilt numpy.

4) I installed matplotlib.

I know this probably seems like overkill, but it is what I had to do
to get my machine working.

Sorry I can't be of more help, these issues are pretty specific to the
individual computer.

Best of luck,

Frank

ยทยทยท

On Wed, Nov 19, 2008 at 4:52 AM, <domenico.inaudi@...1348...> wrote:

Frank Lagor wrote:

Hi,

I am sorry to bug you all with an installation problem, but I need
some additional help to get this figured out.

I previously had a matplotlib installed and working fine, but it was
necessary for me to redo some other installations like numpy when I
needed a complete lapack library. This also led to me installing
another version of g77, because numpy needed a specific library that
was only provide by the g77 version of fortran for some reason.
Anyways, numpy works great but I went back to install matplotlib and I
ran into trouble. After the installation process, if I try to import
matplotlib.pylab I get the following errors:

from matplotlib._path import affine_transform
ImportError: /ronaldo/pkg/dfranci/gcc-g77-3.4.6/lib64/libgcc_s.so.1:
version `GCC_4.2.0' not found (required by /usr/lib64/libstdc++.so.6)

Is this a problem that I can fix in the matplotlib installation or do
I need to go back up to the numpy installation?

I should note that I do not have gcc-4.2.0 on my system.

Thanks in advance,
Frank

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's
challenge
Build the coolest Linux based applications with Moblin SDK & win great
prizes
Grand prize is a trip for two to an Open Source event anywhere in the
world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users

Quoted from:
http://www.nabble.com/Installation-problem-tp20427671p20427671.html

I have the same problem on my portable (windows XP) but everithing works on my desk top!!
Do you have received any answer?
Thanks
Domenico