Installation can't find locally installed Numeric

Hi Alex,

This is really strange. Are you sure all libpng links are correct?
Matplotlib will link only to a name, so you need this link.

Yep, the link is there.

You probably did this already, but I’m going to mention it -
check if the library has the missing symbol:

nm /usr/lib/ | grep png_set_sBIT

Well, I didn’t actually, I’m not that knowledgeable on the linking process (physicist

turned CS researcher, you know, learning as a go along :slight_smile: ). The result is bizarre:

nm: /usr/lib/ no symbols

No symbols? Does this mean the lib is broken? There are quite a lot libs in /usr/lib

which return the same result. The only other lib I’ve installed locally which has libpng

linked in is Qt4, but I haven’t tried that out yet, aside from running the demos, so I can’t

really tell whether it works or not. Any common tools which need libpng to work? Xv, Gimp?

If I know for certain it doesn’t work, I’ll pester our sysadmin about it.

As a final desperate act, install libpng from source in a new directory
and try linking to it (using MPLIB_BASE).

I’ll try that, thanks for the help, I appreciate it.


On 10/13/05, Nadezhda Dencheva <dencheva@…86…> wrote:

Alex Borghgraef

Alexander Borghgraef wrote:

nm: /usr/lib/ no symbols

No symbols? Does this mean the lib is broken?

No, it just means that it's had its symbols stripped for space. It's
still functional; it's just not easy to peek inside.


Robert Kern

"In the fields of hell where the grass grows high
Are the graves of dreams allowed to die."
  -- Richard Harter