How to disable imshow blurring/interpolation

Hi all,

I have just migrated from Matlab to Scipy. Matplotlib has been great so far. However, I have some trouble getting imshow to behave like Matlab’s image function.

If you do image(eye(8)) in matlab, you get this:

http://www.flickr.com/photos/phineasgage/3746211714/

If you do imshow(eye(8)) in matplotlib, you get this:

http://www.flickr.com/photos/phineasgage/3745417651/

How do I get matplotlib to stop interpolating or blurring the borders in the image? I have tried setting interpolation=None (the default behaviour), but this has no effect.

I use matplotlib-0.98.5.2n2 as part of the Enthought distro on Red Hat 4 Linux. Any help would be greatly appreciated.

Johan

Johan Carlin wrote:

Hi all,

I have just migrated from Matlab to Scipy. Matplotlib has been great so far. However, I have some trouble getting imshow to behave like Matlab's image function.

If you do image(eye(8)) in matlab, you get this:

http://www.flickr.com/photos/phineasgage/3746211714/

If you do imshow(eye(8)) in matplotlib, you get this:

http://www.flickr.com/photos/phineasgage/3745417651/

How do I get matplotlib to stop interpolating or blurring the borders in the image? I have tried setting interpolation=None (the default behaviour), but this has no effect.

interpolation='nearest'

Eric

···

I use matplotlib-0.98.5.2n2 as part of the Enthought distro on Red Hat 4 Linux. Any help would be greatly appreciated.

Johan

------------------------------------------------------------------------

------------------------------------------------------------------------------

------------------------------------------------------------------------

_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users