gtk versions: drop support for less than 2.4?

We still require only gtk 2.2, and consequently carry around some extra chunks of code to support versions before 2.4. Can we drop this and require 2.4 or later? Or possibly even a later version? It looks like 2.4 came out in the fall of 2004.

Eric

I'm +1 on dropping support for gtk+ < 2.4 (if even later). Those multiple code paths were a pain, and installing multiple versions of gtk+ for testing is also something I'd like to stop doing.

Cheers,
Mike

Eric Firing wrote:

···

We still require only gtk 2.2, and consequently carry around some extra chunks of code to support versions before 2.4. Can we drop this and require 2.4 or later? Or possibly even a later version? It looks like 2.4 came out in the fall of 2004.

Eric

------------------------------------------------------------------------------
Register Now for Creativity and Technology (CaT), June 3rd, NYC. CaT is a gathering of tech-side developers & brand creativity professionals. Meet
the minds behind Google Creative Lab, Visual Complexity, Processing, & iPhoneDevCamp as they present alongside digital heavyweights like Barbarian Group, R/GA, & Big Spaceship. http://p.sf.net/sfu/creativitycat-com _______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel
  
--
Michael Droettboom
Science Software Branch
Operations and Engineering Division
Space Telescope Science Institute
Operated by AURA for NASA

Michael Droettboom wrote:

I'm +1 on dropping support for gtk+ < 2.4 (if even later). Those multiple code paths were a pain, and installing multiple versions of gtk+ for testing is also something I'd like to stop doing.

Cheers,
Mike

Done.

Eric

···

Eric Firing wrote:

We still require only gtk 2.2, and consequently carry around some extra chunks of code to support versions before 2.4. Can we drop this and require 2.4 or later? Or possibly even a later version? It looks like 2.4 came out in the fall of 2004.

Eric

------------------------------------------------------------------------------

Register Now for Creativity and Technology (CaT), June 3rd, NYC. CaT is a gathering of tech-side developers & brand creativity professionals. Meet
the minds behind Google Creative Lab, Visual Complexity, Processing, & iPhoneDevCamp as they present alongside digital heavyweights like Barbarian Group, R/GA, & Big Spaceship. http://p.sf.net/sfu/creativitycat-com _______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel