gtk.Tooltips() deprecated

Hi,

I just started running PyGTK 2.16 and noticed the following everytime
I run a matplotlib script:

/home/rmay/.local/lib/python2.6/site-packages/matplotlib/backends/backend_gtk.py:621:
DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips = gtk.Tooltips()

Right now, we support >= PyGTK 2.2. The new, non-deperecated API
(gtk.Tooltip) was added in 2.12 (and the gtk.Tooltips API was
deprecated at this time). So, my question is how do we want to handle
this? Do we want to create a helper method that hides the logic to
determine what method to use (there doesn't look to be an easy way to
support both)? Or do we just bump our required version? 2.12.0 was
released in fall 2007. I'm not sure what versions are supplied with
the various distros.

Thoughts?

Ryan

···

--
Ryan May
Graduate Research Assistant
School of Meteorology
University of Oklahoma

Ryan May wrote:

Hi,

I just started running PyGTK 2.16 and noticed the following everytime
I run a matplotlib script:

/home/rmay/.local/lib/python2.6/site-packages/matplotlib/backends/backend_gtk.py:621:
DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips = gtk.Tooltips()

Right now, we support >= PyGTK 2.2. The new, non-deperecated API

pygtk_version_required = (2,4,0)

(gtk.Tooltip) was added in 2.12 (and the gtk.Tooltips API was
deprecated at this time). So, my question is how do we want to handle
this? Do we want to create a helper method that hides the logic to
determine what method to use (there doesn't look to be an easy way to
support both)? Or do we just bump our required version? 2.12.0 was
released in fall 2007. I'm not sure what versions are supplied with
the various distros.

My sense is that RHEL4 is still common, and will be supported by RH through early 2012 (http://www.redhat.com/security/updates/errata/). It is way back at pygtk 2.4.

I just now committed to svn a little bit of conditional code to support the new api along with the old one. Minimal testing on my system (new api) looks OK; more testing with new API, and testing with pygtk < 2.12, are needed. The changes are extremely simple, but I might have overlooked something.

Eric

···

Thoughts?

Ryan

Ryan May wrote:

Hi,

I just started running PyGTK 2.16 and noticed the following everytime
I run a matplotlib script:

/home/rmay/.local/lib/python2.6/site-packages/matplotlib/backends/backend_gtk.py:621:
DeprecationWarning: Use the new widget gtk.Tooltip
self.tooltips = gtk.Tooltips()

Right now, we support >= PyGTK 2.2. The new, non-deperecated API

pygtk_version_required = (2,4,0)

Ok. I got my number from our install docs:
http://matplotlib.sourceforge.net/users/installing.html#build-requirements
There it says PyGTK 2.2 as a (optional) build dependency.

(gtk.Tooltip) was added in 2.12 (and the gtk.Tooltips API was
deprecated at this time). So, my question is how do we want to handle
this? Do we want to create a helper method that hides the logic to
determine what method to use (there doesn't look to be an easy way to
support both)? Or do we just bump our required version? 2.12.0 was
released in fall 2007. I'm not sure what versions are supplied with
the various distros.

My sense is that RHEL4 is still common, and will be supported by RH through
early 2012 (http://www.redhat.com/security/updates/errata/). It is way back
at pygtk 2.4.

I just now committed to svn a little bit of conditional code to support the
new api along with the old one. Minimal testing on my system (new api)
looks OK; more testing with new API, and testing with pygtk < 2.12, are
needed. The changes are extremely simple, but I might have overlooked
something.

Awesome, works great here, thanks.

Ryan

···

On Sat, Mar 20, 2010 at 5:53 PM, Eric Firing <efiring@...229...> wrote:

--
Ryan May
Graduate Research Assistant
School of Meteorology
University of Oklahoma

Ryan May wrote:

···

On Sat, Mar 20, 2010 at 5:53 PM, Eric Firing <efiring@...229...> wrote:

Ryan May wrote:

Hi,

I just started running PyGTK 2.16 and noticed the following everytime
I run a matplotlib script:

/home/rmay/.local/lib/python2.6/site-packages/matplotlib/backends/backend_gtk.py:621:
DeprecationWarning: Use the new widget gtk.Tooltip
self.tooltips = gtk.Tooltips()

Right now, we support >= PyGTK 2.2. The new, non-deperecated API

pygtk_version_required = (2,4,0)

Ok. I got my number from our install docs:
http://matplotlib.sourceforge.net/users/installing.html#build-requirements
There it says PyGTK 2.2 as a (optional) build dependency.

Fixed in svn, thanks.

Eric