'from matplotlib.cbook import is_scalar, dedent' ImportError: cannot import name dedent

Hello List,

I am using python-matplotlib version 0.87.7-0.3ubuntu1(feisty) and
having some problems with a script that uses it. I get this import error
and am not sure how to debug it further, any assistance would be greatly
appreciated.

Best regards,

Paul marsh

···

---------------------------------------------------------------------

crank examples # pwd
/home/a_downloads/basemap-0.9.9.1/examples
crank examples # python simpletest.py
Traceback (most recent call last):
  File "simpletest.py", line 1, in <module>
    from matplotlib.toolkits.basemap import Basemap
  File
"/usr/lib/python2.5/site-packages/matplotlib/toolkits/basemap/__init__.py", line 1, in <module>
    from basemap import __doc__, __version__
  File
"/usr/lib/python2.5/site-packages/matplotlib/toolkits/basemap/basemap.py", line 20, in <module>
    from matplotlib.cbook import is_scalar, dedent
ImportError: cannot import name dedent
crank examples # python -c "from matplotlib.toolkits.basemap import
basemap_datadir;"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File
"/usr/lib/python2.5/site-packages/matplotlib/toolkits/basemap/__init__.py", line 1, in <module>
    from basemap import __doc__, __version__
  File
"/usr/lib/python2.5/site-packages/matplotlib/toolkits/basemap/basemap.py", line 20, in <module>
    from matplotlib.cbook import is_scalar, dedent
ImportError: cannot import name dedent
crank examples #

---------------------------------------------------------------------

It looks like the basemap version you are using is assuming a more
recent version of matplotlib. You will probably either need to
upgrade to more recent matplotlib (0.91.2 is the most recent) or
downgrade to an older basemap.

JDH

···

On Sat, Feb 23, 2008 at 3:25 AM, pmarsh <pmarsh@...1942...> wrote:

Hello List,

I am using python-matplotlib version 0.87.7-0.3ubuntu1(feisty) and
having some problems with a script that uses it. I get this import error
and am not sure how to debug it further, any assistance would be greatly
appreciated.