I have this error. I am running 2.6.5 Python and compiled myself the SVN maybe two weeks ago. The issue came when I tried to compile a version of 2.6.6 using the tcmalloc library. I compiled my own version of Python but had some issues with external packages. I removed 2.6.6 for now. Then I get this error which also occurs in Ipython upon startup. This also was one of the only errors with the 2.6.6 install which makes me think it could have not been with the install.
I was having issues with linking packages such as wxPython2.8 for matplotlib with the usr/local/lib archives. Would I have to compile wxPython myself if I wanted it to go with my compiled version of 2.6.6. This was my next step but just gave up for now. Anyone knows or has compiled there own Python. Please let me know. Especially 2.6 when you already have 2.6 on the system.
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "AuditoryModelT.py", line 1, in <module>
from gammaFilterBank import computeCF, makeFilters, outBank
File "gammaFilterBank.py", line 3, in <module>
from matplotlib.pyplot import plot, clf, show, cla, xlim, xscale, imshow, ylabel, xlabel, figure, savefig, close, bar, title, xticks, yticks, axes, axis
File "/usr/local/lib/python2.6/dist-packages/matplotlib/pyplot.py", line 95, in <module>
new_figure_manager, draw_if_interactive, show = pylab_setup()
File "/usr/local/lib/python2.6/dist-packages/matplotlib/backends/__init__.py", line 25, in pylab_setup
File "/usr/local/lib/python2.6/dist-packages/matplotlib/backends/backend_wxagg.py", line 23, in <module>
import backend_wx # already uses wxversion.ensureMinimal('2.8')
File "/usr/local/lib/python2.6/dist-packages/matplotlib/backends/backend_wx.py", line 65, in <module>
ImportError: Matplotlib backend_wx and backend_wxagg require wxPython >=2.8