Error running examples for Matplotlib

when I try to run the bar plot in the github examples and I get this error(see below), it seems that matplotlib is installed. Does anybody understand why I am getting this error?

to double check I try to re install matplotlib:
johnbarrett@Johns-MBP ~ % pip install matplotlib

Requirement already satisfied: matplotlib in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (3.1.3)

Requirement already satisfied: kiwisolver>=1.0.1 in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from matplotlib) (1.1.0)

Requirement already satisfied: pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from matplotlib) (2.4.6)

Requirement already satisfied: numpy>=1.11 in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from matplotlib) (1.18.1)

Requirement already satisfied: cycler>=0.10 in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from matplotlib) (0.10.0)

Requirement already satisfied: python-dateutil>=2.1 in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from matplotlib) (2.8.1)

Requirement already satisfied: setuptools in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from kiwisolver>=1.0.1->matplotlib) (41.2.0)

Requirement already satisfied: six in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from cycler>=0.10->matplotlib) (1.14.0)

it seems like it’s satisfied

here is the error:

Jupyter Server URI: http://localhost:8888/?token=3130673f39ba1e7b6f1df883e69349332eda4d314a88fbb8
Python version:
3.8.1 (v3.8.1:1b293b6006, Dec 18 2019, 14:08:53) \n[Clang 6.0 (clang-600.0.57)]
(6, 0, 3)
/usr/local/bin/python3
[1]

import matplotlib.pyplot as plt…

ModuleNotFoundError Traceback (most recent call last)
~/tutorial/bar.py in
2 import numpy as np
3
----> 4 import example_utils
5
6

ModuleNotFoundError: No module named ‘example_utils’

Example_utils is not part of matplotlib so far as I know so you’d have to check with whoever example you are running.

@ jklymak thanks so much for replying! I thought that the examples were made from Matplotlib, but it sounds like they are from they community.

Can you please link exactly what examples you’re trying to run? Thanks!