error installing matplotlib-0.98.5

sudo easy_install -U matplotlib
Searching for matplotlib
Reading http://pypi.python.org/simple/matplotlib/
Reading http://matplotlib.sourceforge.net
Reading https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=278194
Reading https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=82474
Reading http://sourceforge.net/project/showfiles.php?group_id=80706
Best match: matplotlib 0.98.5
Downloading http://downloads.sourceforge.net/matplotlib/matplotlib-0.98.5.tar.gz?modtime=1229034572&big_mirror=0
Processing matplotlib-0.98.5.tar.gz
Running matplotlib-0.98.5/setup.py -q bdist_egg --dist-dir /tmp/easy_install-CC1jw7/matplotlib-0.98.5/egg-dist-tmp-NSNvcC

···

============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.5
                python: 2.5.2 (r252:60911, Sep 30 2008, 15:42:03) [GCC
                        4.3.2 20080917 (Red Hat 4.3.2-4)]
              platform: linux2

REQUIRED DEPENDENCIES
                 numpy: 1.2.0
             freetype2: 9.18.3

OPTIONAL BACKEND DEPENDENCIES
                libpng: 1.2.33
               Tkinter: Tkinter: 50704, Tk: 8.5, Tcl: 8.5
                        * Guessing the library and include directories for
                        * Tcl and Tk because the tclConfig.sh and
                        * tkConfig.sh could not be found and/or parsed.
              wxPython: 2.8.9.1
                        * WxAgg extension not required for wxPython >= 2.8
                  Gtk+: gtk+: 2.14.4, glib: 2.18.3, pygtk: 2.13.0,
                        pygobject: 2.15.4
       Mac OS X native: no
                    Qt: Qt: 3.3.8, PyQt: 3.17.4
                   Qt4: Qt: 4.4.1, PyQt4: 4.4.3
                 Cairo: 1.4.12

OPTIONAL DATE/TIMEZONE DEPENDENCIES
              datetime: present, version unknown
              dateutil: 1.4
                  pytz: 2006p

OPTIONAL USETEX DEPENDENCIES
                dvipng: 1.11
           ghostscript: 8.63
                 latex: 3.141592

EXPERIMENTAL CONFIG PACKAGE DEPENDENCIES
             configobj: 4.5.2
      enthought.traits: no

[Edit setup.cfg to suppress the above messages]

error: lib/matplotlib/mpl-data/matplotlib.conf.template: No such file or directory
Exception exceptions.OSError: (2, 'No such file or directory', 'src/image.cpp') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85b3c51b8>> ignored
Exception exceptions.OSError: (2, 'No such file or directory', 'src/path.cpp') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85b3c4638>> ignored
Exception exceptions.OSError: (2, 'No such file or directory', 'src/backend_gdk.c') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85978c7a0>> ignored
Exception exceptions.OSError: (2, 'No such file or directory', 'src/backend_agg.cpp') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85b3c4fc8>> ignored

I'm not seeing this on OSX. Is anyone else experiencing this issue?

- Charlie

···

On Fri, Dec 12, 2008 at 2:39 PM, Neal Becker <ndbecker2@...149...> wrote:

sudo easy_install -U matplotlib
Searching for matplotlib
Reading http://pypi.python.org/simple/matplotlib/
Reading http://matplotlib.sourceforge.net
Reading https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=278194
Reading https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=82474
Reading http://sourceforge.net/project/showfiles.php?group_id=80706
Best match: matplotlib 0.98.5
Downloading http://downloads.sourceforge.net/matplotlib/matplotlib-0.98.5.tar.gz?modtime=1229034572&big_mirror=0
Processing matplotlib-0.98.5.tar.gz
Running matplotlib-0.98.5/setup.py -q bdist_egg --dist-dir /tmp/easy_install-CC1jw7/matplotlib-0.98.5/egg-dist-tmp-NSNvcC

BUILDING MATPLOTLIB
           matplotlib: 0.98.5
               python: 2.5.2 (r252:60911, Sep 30 2008, 15:42:03) [GCC
                       4.3.2 20080917 (Red Hat 4.3.2-4)]
             platform: linux2

REQUIRED DEPENDENCIES
                numpy: 1.2.0
            freetype2: 9.18.3

OPTIONAL BACKEND DEPENDENCIES
               libpng: 1.2.33
              Tkinter: Tkinter: 50704, Tk: 8.5, Tcl: 8.5
                       * Guessing the library and include directories for
                       * Tcl and Tk because the tclConfig.sh and
                       * tkConfig.sh could not be found and/or parsed.
             wxPython: 2.8.9.1
                       * WxAgg extension not required for wxPython >= 2.8
                 Gtk+: gtk+: 2.14.4, glib: 2.18.3, pygtk: 2.13.0,
                       pygobject: 2.15.4
      Mac OS X native: no
                   Qt: Qt: 3.3.8, PyQt: 3.17.4
                  Qt4: Qt: 4.4.1, PyQt4: 4.4.3
                Cairo: 1.4.12

OPTIONAL DATE/TIMEZONE DEPENDENCIES
             datetime: present, version unknown
             dateutil: 1.4
                 pytz: 2006p

OPTIONAL USETEX DEPENDENCIES
               dvipng: 1.11
          ghostscript: 8.63
                latex: 3.141592

EXPERIMENTAL CONFIG PACKAGE DEPENDENCIES
            configobj: 4.5.2
     enthought.traits: no

[Edit setup.cfg to suppress the above messages]

error: lib/matplotlib/mpl-data/matplotlib.conf.template: No such file or directory
Exception exceptions.OSError: (2, 'No such file or directory', 'src/image.cpp') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85b3c51b8>> ignored
Exception exceptions.OSError: (2, 'No such file or directory', 'src/path.cpp') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85b3c4638>> ignored
Exception exceptions.OSError: (2, 'No such file or directory', 'src/backend_gdk.c') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85978c7a0>> ignored
Exception exceptions.OSError: (2, 'No such file or directory', 'src/backend_agg.cpp') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85b3c4fc8>> ignored

------------------------------------------------------------------------------
SF.Net email is Sponsored by MIX09, March 18-20, 2009 in Las Vegas, Nevada.
The future of the web can't happen without you. Join us at MIX09 to help
pave the way to the Next Web now. Learn more and register at
http://ad.doubleclick.net/clk;208669438;13503038;i?http://2009.visitmix.com/
_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

I have experienced the same problem with easy_install on ubuntu-8.4.10 but
it is working with aptitude, so I have done :
sudo aptitude install python-matplotlib

-Fran6

Charlie Moad wrote:

···

I
I'm not seeing this on OSX. Is anyone else experiencing this issue?

- Charlie

On Fri, Dec 12, 2008 at 2:39 PM, Neal Becker <ndbecker2@...149...> wrote:

sudo easy_install -U matplotlib
Searching for matplotlib
Reading http://pypi.python.org/simple/matplotlib/
Reading http://matplotlib.sourceforge.net
Reading
https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=278194
Reading
https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=82474
Reading http://sourceforge.net/project/showfiles.php?group_id=80706
Best match: matplotlib 0.98.5
Downloading
http://downloads.sourceforge.net/matplotlib/matplotlib-0.98.5.tar.gz?modtime=1229034572&big_mirror=0
Processing matplotlib-0.98.5.tar.gz
Running matplotlib-0.98.5/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-CC1jw7/matplotlib-0.98.5/egg-dist-tmp-NSNvcC

BUILDING MATPLOTLIB
           matplotlib: 0.98.5
               python: 2.5.2 (r252:60911, Sep 30 2008, 15:42:03) [GCC
                       4.3.2 20080917 (Red Hat 4.3.2-4)]
             platform: linux2

REQUIRED DEPENDENCIES
                numpy: 1.2.0
            freetype2: 9.18.3

OPTIONAL BACKEND DEPENDENCIES
               libpng: 1.2.33
              Tkinter: Tkinter: 50704, Tk: 8.5, Tcl: 8.5
                       * Guessing the library and include directories for
                       * Tcl and Tk because the tclConfig.sh and
                       * tkConfig.sh could not be found and/or parsed.
             wxPython: 2.8.9.1
                       * WxAgg extension not required for wxPython >= 2.8
                 Gtk+: gtk+: 2.14.4, glib: 2.18.3, pygtk: 2.13.0,
                       pygobject: 2.15.4
      Mac OS X native: no
                   Qt: Qt: 3.3.8, PyQt: 3.17.4
                  Qt4: Qt: 4.4.1, PyQt4: 4.4.3
                Cairo: 1.4.12

OPTIONAL DATE/TIMEZONE DEPENDENCIES
             datetime: present, version unknown
             dateutil: 1.4
                 pytz: 2006p

OPTIONAL USETEX DEPENDENCIES
               dvipng: 1.11
          ghostscript: 8.63
                latex: 3.141592

EXPERIMENTAL CONFIG PACKAGE DEPENDENCIES
            configobj: 4.5.2
     enthought.traits: no

[Edit setup.cfg to suppress the above messages]

error: lib/matplotlib/mpl-data/matplotlib.conf.template: No such file or
directory
Exception exceptions.OSError: (2, 'No such file or directory',
'src/image.cpp') in <bound method CleanUpFile.__del__ of
<setupext.CleanUpFile instance at 0x7fc85b3c51b8>> ignored
Exception exceptions.OSError: (2, 'No such file or directory',
'src/path.cpp') in <bound method CleanUpFile.__del__ of
<setupext.CleanUpFile instance at 0x7fc85b3c4638>> ignored
Exception exceptions.OSError: (2, 'No such file or directory',
'src/backend_gdk.c') in <bound method CleanUpFile.__del__ of
<setupext.CleanUpFile instance at 0x7fc85978c7a0>> ignored
Exception exceptions.OSError: (2, 'No such file or directory',
'src/backend_agg.cpp') in <bound method CleanUpFile.__del__ of
<setupext.CleanUpFile instance at 0x7fc85b3c4fc8>> ignored

------------------------------------------------------------------------------
SF.Net email is Sponsored by MIX09, March 18-20, 2009 in Las Vegas,
Nevada.
The future of the web can't happen without you. Join us at MIX09 to help
pave the way to the Next Web now. Learn more and register at
http://ad.doubleclick.net/clk;208669438;13503038;i?http://2009.visitmix.com/
_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

------------------------------------------------------------------------------
SF.Net email is Sponsored by MIX09, March 18-20, 2009 in Las Vegas,
Nevada.
The future of the web can't happen without you. Join us at MIX09 to help
pave the way to the Next Web now. Learn more and register at
http://ad.doubleclick.net/clk;208669438;13503038;i?http://2009.visitmix.com/
_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

--
View this message in context: http://www.nabble.com/error-installing-matplotlib-0.98.5-tp20982264p21001317.html
Sent from the matplotlib - devel mailing list archive at Nabble.com.

Yes, but unfortunately, not every OS has a good packaging system like
apt-get/aptitude (and this is actually the reason I use Ubuntu, but
people should be free to choose their OS).

Gaël

···

On Sun, Dec 14, 2008 at 07:30:19AM -0800, fraka6 wrote:

I have experienced the same problem with easy_install on ubuntu-8.4.10 but
it is working with aptitude, so I have done :
sudo aptitude install python-matplotlib

It is a little annoying because I wast thinking of using Extension module
from distutils.core to create my library setup.py that seems to use
easy_install. As suggested in my
http://fraka6.blogspot.com/2008/12/swig-and-python.html blog I will try to
use scipy.mlab interface instead. Yes aptitude is great for ubuntu users.

Fran6

Gael Varoquaux-2 wrote:

···

On Sun, Dec 14, 2008 at 07:30:19AM -0800, fraka6 wrote:

I have experienced the same problem with easy_install on ubuntu-8.4.10
but
it is working with aptitude, so I have done :
sudo aptitude install python-matplotlib

Yes, but unfortunately, not every OS has a good packaging system like
apt-get/aptitude (and this is actually the reason I use Ubuntu, but
people should be free to choose their OS).

Gaël

------------------------------------------------------------------------------
SF.Net email is Sponsored by MIX09, March 18-20, 2009 in Las Vegas,
Nevada.
The future of the web can't happen without you. Join us at MIX09 to help
pave the way to the Next Web now. Learn more and register at
http://ad.doubleclick.net/clk;208669438;13503038;i?http://2009.visitmix.com/
_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

--
View this message in context: http://www.nabble.com/error-installing-matplotlib-0.98.5-tp20982264p21007850.html
Sent from the matplotlib - devel mailing list archive at Nabble.com.

AFAIK, Extension doesn't need setuptools (setuptools is the libraryy
providing easy_install). If you have a problem here, you'll have to tell
us a bot more about it.

Cheers,

Gaël

···

On Sun, Dec 14, 2008 at 07:33:57PM -0800, fraka6 wrote:

It is a little annoying because I wast thinking of using Extension module
from distutils.core to create my library setup.py that seems to use
easy_install.