easy_install and pip install both fail

Hello,

I’m having a problem getting matplotlib to work with either easy_install or pip install. I’ve tries all sorts of options from easy_install matplotlib, pip install matplotlib, easy_install http://downloads.sourceforge.net/project/matplotlib/matplotlib/matplotlib-0.98.5/matplotlib-0.98.5.3.tar.gz The error which causes both to fail is:

lipo: can’t figure
out the architecture type of: /var/folders/vO/vOCgTRh6FuWMIH2kWdCZgk+++TM/-Tmp-//ccaBo27K.out

error: Setup script exited with error: command ‘gcc-4.0’ failed with exit status 1

I can get matplotlib working if I download from sourceforge and install manually but I will need to distribute my project and since matplotlib will be a dependecy this is not an option. So how can I get matplotlib to install with either easy_install or pip ?

Regards,

Bogdan

Neacsa Bogdan Valentin, on 2011-07-12 03:00, wrote:

I'm having a problem getting matplotlib to work with either
easy_install or pip install. I've tries all sorts of options
from easy_install matplotlib, pip install matplotlib,
easy_install
http://downloads.sourceforge.net/project/matplotlib/matplotlib/matplotlib-0.98.5/matplotlib-0.98.5.3.tar.gz
The error which causes both to fail is:

Hi Bogdan,

are you specifically trying to install that old version of
matplotlib? If not, add the -U flag to easy_install to try to
grab a newer version

best,

···

--
Paul Ivanov
314 address only used for lists, off-list direct email at:
http://pirsquared.org | GPG/PGP key id: 0x0F3E28F7