Hi all,

Yeah, it definitely seems like there's a bit too much here.

well, running "apt-get build-dep matplolib" you'll get all the
dependecies needed to build all the part of matplotlib, both the
module and the documentation; so it's surely a super-set of the
packages needed only for doc... but... in order to build the doc, you
need to build mpl module first, since it's used by the doc itself.

Sure. I understand these are needed for both matplotlib itself and the docs. I still think there's some extras, though.

I think some of
these dependencies are obsolete, in that we used to build extensions against
gtk and wx in order to transfer image data to those backends, but those are
no longer needed with current versions of those libraries.

I looked up the direct dependencies of the package (since I think many on
the list you provided are probably secondary dependencies.) I have some
comments below. Maybe Sandro Tosi, who I know has done some Debian
packaging of matplotlib in the past,

and I'm keep doing it these days :slight_smile:

Great -- I didn't mean to imply you weren't still working on it :wink: Thanks, as always, for all the work you've done on that.

libfreetype6-dev - legit
libgtk2.0-dev - **no longer necessary**

mh, the GTK+ backend is built as an extensions, so it should require
the development files to be built - f.e. I can see it "#include

Sorry -- I had misremembered. It's Qt and Wx that used to have C/C++ extensions that are no longer required. It seems we still need this for Gtk, so you're right -- this is a legitimate build dependency.

libpng-dev - legit
python-all-dbg (>= 2.4.4-6) - **not strictly necessary, but helpful for

that's because we're providing a debug-flavor extension, so we need
the debug-enabled interpreters


python-all-dev (>= 2.3.5-7) - legit
python-configobj - **necessary only for a long abandoned experimental
version of matplotlib**

I'll look if it can be removed - at a first glance it should be safe to rm it

python-dateutil - legit
python-epydoc - **obsolete**

I'll see if it can be removed

python-gtk2-dev - **obsolete**

see above


python-imaging - legit
python-numpy (>= 1:1.3.0) - legit
python-numpy-dbg (>= 1:1.3.0) - legit
python-pkg-resources - legit
python-qt4 - **not needed for build**
python-qt4-dev - **not needed for build**

same as GTK+ backend

Nope. There is no Qt C++ extension anymore (hasn't been for years). The only dependency is on python-qt4, and only at runtime, not build time, technically.

python-qt-dev - **obsolete**

yeah it might now just be a transitional package towards
python-qt4-dev - I'll check this

python-setuptools - legit
python-sphinx (>= 0.5.1) - to build the documentation
python-support (>= 1.0.0) - not sure what this is

it's a debian tool to setup python modules/extensions for Debian systems


python-tk (>= 2.5.2-1.1) - legit
python-traits (>= 2.0) - **not needed -- matplotlib doesn't use traits**

yep, I'll remove it

python-tz - legit
python-wxgtk2.8 - **not needed for build**
python-wxgtk2.8-dbg - **not needed for build**

I'll look into this

Same issue as for Qt/Qt4 -- there's no C code that links to it.

tcl8.5-dev - legit
texlive-fonts-recommended - needed for PDF doc build
texlive-latex-extra - needed for PDF doc build
texlive-latex-recommended - needed for PDF doc build

that's probably where the big part of the download will come

Agreed. But why would anyone not want TeX installed? :slight_smile:

tk8.5-dev - legit
zlib1g-dev - legit

Thanks a lot for the review: it will help improving the package!




On 05/03/2012 07:47 AM, Sandro Tosi wrote:

On Thu, May 3, 2012 at 1:25 PM, Michael Droettboom<mdroe@...86...> wrote: