crash on MacOS X (more info)

In article <rowen-B27192.13484215092006@...328...>,
"Russell E. Owen" <rowen@...529...>
wrote:

I'm trying to figure out a matplotlib crash on MacOS X.

When I try to plot anything the program exits with:
alloc: invalid block: 0xa08acb4: a 74 0

...
some followup info:
- This is with matplotlib 0.87.5, but also seen with 0.87.4 and 0.87.2
- This is with ActiveState Tcl/Tk 8.4.11, not 8.4.13 as I originally said

I tried the test again with "debug-annoying" level logging. Before
running it I:
- deleted everything in ~/.matplotlibrc.
- .../site-packages/matplotlib/mpl-data to ~/.matplotlibrc and stripped
out all but a few options (something I'd never tried before, but I'm
hoping it'll leave me a matplotlibrc file that is compatible with future
versions of matplotlib, for a change):

backend : TkAgg
numerix : numarray
interactive : False
verbose.level : debug-annoying
verbose.fileo : sys.stdout

I then ran the test:

from pylab import *
plot([1,2,3,4])
show()

The crash happens after the show():
...
RendererAgg.draw_text
RendererAgg._get_agg_font
alloc: invalid block: 0xa08acb4: a 74 0

The full log is here:
<http://rowen.astro.washington.edu/mpl.txt>

One other thing that may be relevant (and is in the log): whenever I run
matplotlib for the first time after deleting the font cache, I always
get a spate of warnings like this:
455: UserWarning: Could not open font file
/System/Library/Fonts/LastResort.dfont

-- Russell