Could not obtain dvipng version

SVN has a runtime error when checking for dvipng when I am not even
using it. Pretty much breaks everything right now.

cmoad@...342...:~$ python
Python 2.4.3 (#2, Mar 30 2006, 14:45:01)
[GCC 4.0.3 (Ubuntu 4.0.3-1ubuntu3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.

from pylab import *
plot(rand(100))

[<matplotlib.lines.Line2D instance at 0x7584d76c>]

show()

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686.egg/matplotlib/backends/backend_gtk.py",
line 293, in expose_event
    self._render_figure(self._pixmap, w, h)
  File "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686.egg/matplotlib/backends/backend_gtkagg.py",
line 72, in _render_figure
    FigureCanvasAgg.draw(self)
  File "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686.egg/matplotlib/backends/backend_agg.py",
line 397, in draw
    renderer = self.get_renderer()
  File "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686.egg/matplotlib/backends/backend_agg.py",
line 408, in get_renderer
    self.renderer = RendererAgg(w, h, self.figure.dpi)
  File "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686.egg/matplotlib/backends/backend_agg.py",
line 136, in __init__
    self.texmanager = TexManager()
  File "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686.egg/matplotlib/texmanager.py",
line 96, in __init__
    self.dvipngVersion = self.get_dvipng_version()
  File "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686.egg/matplotlib/texmanager.py",
line 427, in get_dvipng_version
    if exit_status: raise RuntimeError('Could not obtain dvipng version\n\
RuntimeError: Could not obtain dvipng version

Sorry about that, I didnt see that one coming.

This should be fixed in svn 2278.

Darren

···

On Monday 10 April 2006 8:46 am, Charlie Moad wrote:

SVN has a runtime error when checking for dvipng when I am not even
using it. Pretty much breaks everything right now.

cmoad@...342...:~$ python
Python 2.4.3 (#2, Mar 30 2006, 14:45:01)
[GCC 4.0.3 (Ubuntu 4.0.3-1ubuntu3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.

>>> from pylab import *
>>> plot(rand(100))

[<matplotlib.lines.Line2D instance at 0x7584d76c>]

>>> show()

Traceback (most recent call last):
  File
"/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
.egg/matplotlib/backends/backend_gtk.py", line 293, in expose_event
    self._render_figure(self._pixmap, w, h)
  File
"/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
.egg/matplotlib/backends/backend_gtkagg.py", line 72, in _render_figure
    FigureCanvasAgg.draw(self)
  File
"/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
.egg/matplotlib/backends/backend_agg.py", line 397, in draw
    renderer = self.get_renderer()
  File
"/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
.egg/matplotlib/backends/backend_agg.py", line 408, in get_renderer
    self.renderer = RendererAgg(w, h, self.figure.dpi)
  File
"/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
.egg/matplotlib/backends/backend_agg.py", line 136, in __init__
    self.texmanager = TexManager()
  File
"/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
.egg/matplotlib/texmanager.py", line 96, in __init__
    self.dvipngVersion = self.get_dvipng_version()
  File
"/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
.egg/matplotlib/texmanager.py", line 427, in get_dvipng_version
    if exit_status: raise RuntimeError('Could not obtain dvipng version\n\
RuntimeError: Could not obtain dvipng version

-------------------------------------------------------
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live
webcast and join the prime developer group breaking into this new coding
territory!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid0944&bid$1720&dat1642
_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

--
Darren S. Dale, Ph.D.
dd55@...143...

Thanks. I didn't mean to be terse or anything, but I just figured
someone would know what to fix off the top of their head.

- Charlie

···

On 4/10/06, Darren Dale <dd55@...143...> wrote:

Sorry about that, I didnt see that one coming.

This should be fixed in svn 2278.

Darren

On Monday 10 April 2006 8:46 am, Charlie Moad wrote:
> SVN has a runtime error when checking for dvipng when I am not even
> using it. Pretty much breaks everything right now.
>
> cmoad@...342...:~$ python
> Python 2.4.3 (#2, Mar 30 2006, 14:45:01)
> [GCC 4.0.3 (Ubuntu 4.0.3-1ubuntu3)] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
>
> >>> from pylab import *
> >>> plot(rand(100))
>
> [<matplotlib.lines.Line2D instance at 0x7584d76c>]
>
> >>> show()
>
> Traceback (most recent call last):
> File
> "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
>.egg/matplotlib/backends/backend_gtk.py", line 293, in expose_event
> self._render_figure(self._pixmap, w, h)
> File
> "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
>.egg/matplotlib/backends/backend_gtkagg.py", line 72, in _render_figure
> FigureCanvasAgg.draw(self)
> File
> "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
>.egg/matplotlib/backends/backend_agg.py", line 397, in draw
> renderer = self.get_renderer()
> File
> "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
>.egg/matplotlib/backends/backend_agg.py", line 408, in get_renderer
> self.renderer = RendererAgg(w, h, self.figure.dpi)
> File
> "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
>.egg/matplotlib/backends/backend_agg.py", line 136, in __init__
> self.texmanager = TexManager()
> File
> "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
>.egg/matplotlib/texmanager.py", line 96, in __init__
> self.dvipngVersion = self.get_dvipng_version()
> File
> "/usr/lib/python2.4/site-packages/matplotlib-0.88dev_r2277-py2.4-linux-i686
>.egg/matplotlib/texmanager.py", line 427, in get_dvipng_version
> if exit_status: raise RuntimeError('Could not obtain dvipng version\n\
> RuntimeError: Could not obtain dvipng version
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by xPML, a groundbreaking scripting language
> that extends applications into web and mobile media. Attend the live
> webcast and join the prime developer group breaking into this new coding
> territory!
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid0944&bid$1720&dat1642
> _______________________________________________
> Matplotlib-devel mailing list
> Matplotlib-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

--
Darren S. Dale, Ph.D.
dd55@...143...

-------------------------------------------------------
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=110944&bid=241720&dat=121642
_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel