compile error with python2.5

Hello Charlie!

Hmmm... Basically you are right. But maybe you are more familiar with
SWIG issues than I am.

Ok, I will do the job and go to swig and have a look:

http://swig.cvs.sourceforge.net/swig/SWIG/Lib/python/pyrun.swg?r1=1.143&r2=1.144

You will find this error corrected five months ago.

You are using version: 1.3.27 (as stated in the file's header), the last
official release is 1.3.12 (June 2006) and the latest cvs version 1.3.30
(in progress). I do not understand why this version is not in use...

Maybe you should try the latest SWIG version.

Yours, Achim

Charlie Moad wrote:

···

Thanks for the patch. Ideally we need to find a way to fix this in
swig though. Otherwise we would have to reapply the patch every time
we regenerate the wrappings.

This came up on the dev list yesterday and we tried with swig-1.3.29,
which is the latest listed release on SF. The link you provided shows
this was indeed fixed after the 1.3.29 release. Jon, can we give
bleeding edge swig a try?

Thanks,
     Charlie

···

On 9/20/06, Achim Gaedke <Achim.Gaedke@...759...> wrote:

Hello Charlie!

Hmmm... Basically you are right. But maybe you are more familiar with
SWIG issues than I am.

Ok, I will do the job and go to swig and have a look:

http://swig.cvs.sourceforge.net/swig/SWIG/Lib/python/pyrun.swg?r1=1.143&r2=1.144

You will find this error corrected five months ago.

You are using version: 1.3.27 (as stated in the file's header), the last
official release is 1.3.12 (June 2006) and the latest cvs version 1.3.30
(in progress). I do not understand why this version is not in use...

Maybe you should try the latest SWIG version.

Yours, Achim

Charlie Moad wrote:
> Thanks for the patch. Ideally we need to find a way to fix this in
> swig though. Otherwise we would have to reapply the patch every time
> we regenerate the wrappings.