>> def set_aspect(self, aspect='auto', fixLimits=None,
>> aspect_adjusts='position'): """ aspect: 'auto' - automatic;
A minor nit: I'm not fond of underscores in kwargs, and prefer them to
be as short and as easy to type as possible. I think "aspects" in
"aspect_adjusts" is a bit redundant since the method is "set_aspect"
and prefer "adjust" or something similarly simple. Also, perhaps we
could take this opportunity while changing the API to replace
fixLimits with fixlimits (if it survives the refactor).
I think as a general matter, we should stick to strictly lowercase, no
underscores for kwargs where possible. Granted not all kwargs work
this way currently, but most do and I prefer this style.