Cannot build matplot on OS X: libfreetype.dylib and libiconv.2.dylib are not of the right architecture

I am trying to install matplot on an OS X (10.5.7) Intel MacBook. I
cannot build the matplot lib extensions. I get the following error:

....
g++ -arch i386 -arch ppc -isysroot /Developer/SDKs/MacOSX10.4u.sdk
-bundle -undefined dynamic_lookup
build/temp.macosx-10.3-i386-2.5/src/ft2font.o
build/temp.macosx-10.3-i386-2.5/src/mplutils.o
build/temp.macosx-10.3-i386-2.5/CXX/cxx_extensions.o
build/temp.macosx-10.3-i386-2.5/CXX/cxxsupport.o
build/temp.macosx-10.3-i386-2.5/CXX/IndirectPythonInterface.o
build/temp.macosx-10.3-i386-2.5/CXX/cxxextensions.o -L/sw/lib
-L/sw/lib/freetype219/lib -L/usr/local/lib -L/usr/lib -L/sw/lib
-L/usr/X11R6/lib -lfreetype -lz -lstdc++ -lm -o
build/lib.macosx-10.3-i386-2.5/matplotlib/ft2font.so
-Wl,-framework,CoreServices -Wl,-framework,ApplicationServices
ld warning: in /sw/lib/libfreetype.dylib, file is not of required architecture
ld: in /sw/lib/libiconv.2.dylib, file is not of required architecture
for architecture ppc
collect2: ld returned 1 exit status
lipo: can't open input file:
/var/folders/xW/xW61KykkHgSaGc2vPwOTCk+++TI/-Tmp-//ccGEBvWb.out (No
such file or directory)
error: command 'g++' failed with exit status 1

This is matplotlib-0.91.4. I get the same error whether I install via
the egg or download the zipped tar ball and run "python setup.py
build".

The libraries in "/sw/lib" were installed by the fink package manager.

In particular I don't understand the error message about
libiconv.2.dylib being "not of required architecture for architecture
ppc". It seems like matplot lib thinks it's building on a PPC instead
of an Intel machine.

I'm running Active State Python 2.5.4.

Any suggestions for how to get matplotlib working on my machine?

Thanks.

···

--
W.P. McNeill
http://staff.washington.edu/billmcn/index.shtml

That's quite an old version. Could you try with a more recent release?
0.98.5.3 is the latest release and it builds for me on OS X 10.5.7
without problems. (You need to close the matplotlib-maintenance tree
on sourceforge and look for files in 'matplotlib' branch instead)

Cheers

Robin

···

On Thu, Jul 9, 2009 at 10:13 PM, W.P. McNeill<billmcn@...287...> wrote:

This is matplotlib-0.91.4. I get the same error whether I install via
the egg or download the zipped tar ball and run "python setup.py
build".

That worked. I was able to install matplotlib-0.98.5.3-py2.5-macosx10.5.zip.

Thanks.

···

On Thu, Jul 9, 2009 at 3:51 PM, Robin <robince@…287…> wrote:

On Thu, Jul 9, 2009 at 10:13 PM, W.P. McNeill<billmcn@…287…> wrote:

This is matplotlib-0.91.4. I get the same error whether I install via

the egg or download the zipped tar ball and run "python setup.py

build".

That’s quite an old version. Could you try with a more recent release?

0.98.5.3 is the latest release and it builds for me on OS X 10.5.7

without problems. (You need to close the matplotlib-maintenance tree

on sourceforge and look for files in ‘matplotlib’ branch instead)

Cheers

Robin


W.P. McNeill
http://staff.washington.edu/billmcn/index.shtml

It looks like there is an incompatibility with the freetype supplied
in /sw (probably fink supplied). Perhaps it is not configured as a
universal binary.

You can build mpl from svn the way we do when we make a release, which
will automatically fetch and build the dependencies correctly. First
see,

  http://matplotlib.sourceforge.net/faq/installing_faq.html#which-python-for-osx

then grab a copy of mpl from svn

  http://matplotlib.sourceforge.net/faq/installing_faq.html#install-svn

and cd into the releases/osx directory and follow the instructions in
the README there.

JDH

···

On Thu, Jul 9, 2009 at 4:13 PM, W.P. McNeill<billmcn@...287...> wrote:

I am trying to install matplot on an OS X (10.5.7) Intel MacBook. I
cannot build the matplot lib extensions. I get the following error:

....
g++ -arch i386 -arch ppc -isysroot /Developer/SDKs/MacOSX10.4u.sdk
-bundle -undefined dynamic_lookup
build/temp.macosx-10.3-i386-2.5/src/ft2font.o
build/temp.macosx-10.3-i386-2.5/src/mplutils.o
build/temp.macosx-10.3-i386-2.5/CXX/cxx_extensions.o
build/temp.macosx-10.3-i386-2.5/CXX/cxxsupport.o
build/temp.macosx-10.3-i386-2.5/CXX/IndirectPythonInterface.o
build/temp.macosx-10.3-i386-2.5/CXX/cxxextensions.o -L/sw/lib
-L/sw/lib/freetype219/lib -L/usr/local/lib -L/usr/lib -L/sw/lib
-L/usr/X11R6/lib -lfreetype -lz -lstdc++ -lm -o
build/lib.macosx-10.3-i386-2.5/matplotlib/ft2font.so
-Wl,-framework,CoreServices -Wl,-framework,ApplicationServices
ld warning: in /sw/lib/libfreetype.dylib, file is not of required architecture
ld: in /sw/lib/libiconv.2.dylib, file is not of required architecture
for architecture ppc
collect2: ld returned 1 exit status
lipo: can't open input file:
/var/folders/xW/xW61KykkHgSaGc2vPwOTCk+++TI/-Tmp-//ccGEBvWb.out (No
such file or directory)
error: command 'g++' failed with exit status 1

Hi,

I get the same errors when I follow those instructions. I have a very new 17" MacBook Pro running 10.5.7. I’ve installed the Enthought Python Distribution. These commands worked correctly:

unset PKG_CONFIG_PATH
make fetch_deps
cd bdist_mpkg-0.4.3
sudo python setup.py install
cd ..
make dependencies
cd ../..
python setup.py sdist
mv dist/matplotlib-0.98.6svn.tar.gz release/osx/

cd release/osx

I then edit the Makefile and change

MPLVERSION=0.98.5.3

to

MPLVERSION=0.98.6svn

but the next command,

make installers

produces the error:

… < blah blah untarring > …

···

On Sat, Jul 11, 2009 at 9:05 AM, John Hunter <jdh2358@…83…287…> wrote:

It looks like there is an incompatibility with the freetype supplied

in /sw (probably fink supplied). Perhaps it is not configured as a

universal binary.

You can build mpl from svn the way we do when we make a release, which

will automatically fetch and build the dependencies correctly. First

see,

http://matplotlib.sourceforge.net/faq/installing_faq.html#which-python-for-osx

then grab a copy of mpl from svn

http://matplotlib.sourceforge.net/faq/installing_faq.html#install-svn

and cd into the releases/osx directory and follow the instructions in

the README there.

============================================================================
BUILDING MATPLOTLIB
matplotlib: 0.98.6svn
python: 2.5.4 |EPD_Py25 4.3.0| (r254:67916, May 17 2009,
20:07:12) [GCC 4.0.1 (Apple Computer, Inc. build

                    5370)]
          platform: darwin

REQUIRED DEPENDENCIES
numpy: 1.3.0
freetype2: found, but unknown version (no pkg-config)

OPTIONAL BACKEND DEPENDENCIES

            libpng: found, but unknown version (no pkg-config)
           Tkinter: Tkinter: 67737, Tk: 8.4, Tcl: 8.4
          wxPython: 2.8.7.1
                    * WxAgg extension not required for wxPython >= 2.8

              Gtk+: no
                    * Building for Gtk+ requires pygtk; you must be able
                    * to "import gtk" in your build/install environment
   Mac OS X native: yes

                Qt: no
               Qt4: no
             Cairo: no

OPTIONAL DATE/TIMEZONE DEPENDENCIES
datetime: present, version unknown
dateutil: matplotlib will provide

              pytz: matplotlib will provide

adding pytz

OPTIONAL USETEX DEPENDENCIES
dvipng: no
ghostscript: /bin/sh: gs: command not found
latex: no

[Edit setup.cfg to suppress the above messages]

pymods [‘pylab’]
packages [‘matplotlib’, ‘matplotlib.backends’, ‘matplotlib.projections’, ‘mpl_toolkits’, ‘mpl_toolkits.mplot3d’, ‘mpl_toolkits.axes_grid’, ‘matplotlib.sphinxext’, ‘matplotlib.numerix’, ‘matplotlib.numerix.mlab’, ‘matplotlib.numerix.ma’, ‘matplotlib.numerix.linear_algebra’, ‘matplotlib.numerix.random_array’, ‘matplotlib.numerix.fft’, ‘matplotlib.delaunay’, ‘pytz’, ‘dateutil’, ‘dateutil/zoneinfo’]

running bdist_mpkg
installing to build/bdist.macosx-10.3-fat/mpkg
running build
running build_py
creating build
creating build/lib.macosx-10.3-fat-2.5
copying lib/pylab.py -> build/lib.macosx-10.3-fat-2.5

creating build/lib.macosx-10.3-fat-2.5/matplotlib

… < blah blah, copying > …

creating build/temp.macosx-10.3-fat-2.5/CXX
gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c src/ft2font.cpp -o build/temp.macosx-10.3-fat-2.5/src/ft2font.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c src/mplutils.cpp -o build/temp.macosx-10.3-fat-2.5/src/mplutils.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c CXX/cxx_extensions.cxx -o build/temp.macosx-10.3-fat-2.5/CXX/cxx_extensions.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c CXX/cxxsupport.cxx -o build/temp.macosx-10.3-fat-2.5/CXX/cxxsupport.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c CXX/IndirectPythonInterface.cxx -o build/temp.macosx-10.3-fat-2.5/CXX/IndirectPythonInterface.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c CXX/cxxextensions.c -o build/temp.macosx-10.3-fat-2.5/CXX/cxxextensions.o

g++ -arch i386 -arch ppc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -g -L/usr/local/lib -L/Library/Frameworks/Python.framework/Versions/4.3.0/lib -bundle -undefined dynamic_lookup -arch ppc -arch i386 -L/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -L/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -L/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7 -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include build/temp.macosx-10.3-fat-2.5/src/ft2font.o build/temp.macosx-10.3-fat-2.5/src/mplutils.o build/temp.macosx-10.3-fat-2.5/CXX/cxx_extensions.o build/temp.macosx-10.3-fat-2.5/CXX/cxxsupport.o build/temp.macosx-10.3-fat-2.5/CXX/IndirectPythonInterface.o build/temp.macosx-10.3-fat-2.5/CXX/cxxextensions.o -L/usr/local/lib -L/usr/lib -L/usr/X11R6/lib -lfreetype -lz -lstdc++ -lm -o build/lib.macosx-10.3-fat-2.5/matplotlib/ft2font.so

ld warning: in /Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/Python.framework/Versions/4.3.0/lib/libz.dylib, file is not of required architecture
ld warning: in /Developer/SDKs/MacOSX10.4u.sdk/usr/local/lib/libgcc_s.10.4.dylib, missing required architecture ppc in file

ld: in /Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/Python.framework/Versions/4.3.0/lib/libz.1.dylib, file is not of required architecture for architecture ppc
collect2: ld returned 1 exit status
lipo: can’t open input file: /var/folders/mr/mrDdnQgUEQWRcRe-wF1uFE+++TI/-Tmp-//ccvdMAI3.out (No such file or directory)

error: command ‘g++’ failed with exit status 1
make: *** [installers] Error 1

It appears that I have no idea how the OS X build system works, because I’m quite surprised by all of the seeming references to 10.3 and 10.4, given that I’m running 10.5.

I’d be quite happy to provide further information. I’m happy with the stock matplotlib on my system, but I’d like to get this working so I can submit my tiny patch to acorr/xcorr.

Thanks,

-michael

JDH


Enter the BlackBerry Developer Challenge

This is your chance to win up to $100,000 in prizes! For a limited time,

vendors submitting new applications to BlackBerry App World™ will have

the opportunity to enter the BlackBerry Developer Challenge. See full prize

details at: http://p.sf.net/sfu/Challenge


Matplotlib-users mailing list

Matplotlib-users@lists.sourceforge.net

https://lists.sourceforge.net/lists/listinfo/matplotlib-users


Michael Lerner, Ph.D.
IRTA Postdoctoral Fellow
Laboratory of Computational Biology NIH/NHLBI
5635 Fishers Lane, Room T909, MSC 9314
Rockville, MD 20852 (UPS/FedEx/Reality)

Bethesda MD 20892-9314 (USPS)

Hi all,

I tried this again with a clean checkout from svn:

svn co https://matplotlib.svn.sourceforge.net/svnroot/matplotlib/trunk/matplotlib matplotlib
(checks out revision 7262)
cd matplotlib/release/osx/
unset PKG_CONFIG_PATH
make fetch_deps
cd bdist_mpkg-0.4.3
sudo python setup.py install
cd …
make dependencies
cd …/…
python setup.py sdist
mv dist/matplotlib-0.98.6svn.tar.gz release/osx/
cd release/osx

make installers

and it fails. Here are the last couple of lines:

g++ -arch i386 -arch ppc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -g -L/usr/local/lib -L/Library/Frameworks/Python.framework/Versions/4.3.0/lib -bundle -undefined dynamic_lookup -arch ppc -arch i386 -L/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -L/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -L/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7 -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include build/temp.macosx-10.3-fat-2.5/src/ft2font.o build/temp.macosx-10.3-fat-2.5/src/mplutils.o build/temp.macosx-10.3-fat-2.5/CXX/cxx_extensions.o build/temp.macosx-10.3-fat-2.5/CXX/cxxsupport.o build/temp.macosx-10.3-fat-2.5/CXX/IndirectPythonInterface.o build/temp.macosx-10.3-fat-2.5/CXX/cxxextensions.o -L/usr/local/lib -L/usr/lib -L/usr/X11R6/lib -lfreetype -lz -lstdc++ -lm -o build/lib.macosx-10.3-fat-2.5/matplotlib/ft2font.so
ld warning: in /Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/Python.framework/Versions/4.3.0/lib/libz.dylib, file is not of required architecture
ld warning: in /Developer/SDKs/MacOSX10.4u.sdk/usr/local/lib/libgcc_s.10.4.dylib, missing required architecture ppc in file
ld: in /Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/Python.framework/Versions/4.3.0/lib/libz.1.dylib, file is not of required architecture for architecture ppc
collect2: ld returned 1 exit status
lipo: can’t open input file: /var/folders/mr/mrDdnQgUEQWRcRe-wF1uFE+++TI/-Tmp-//ccAjnLEy.out (No such file or directory)
error: command ‘g++’ failed with exit status 1
make: *** [installers] Error 1
laptop-36:osx mglerner$

as I mentioned before, I’m not intimately familiar with the OS X build process, but I’d be happy to provide additional information/testing.

Thanks,

-michael

···

On Sat, Jul 11, 2009 at 4:31 PM, Michael Lerner <mglerner@…287…> wrote:

On Sat, Jul 11, 2009 at 9:05 AM, John Hunter <jdh2358@…287…> wrote:

It looks like there is an incompatibility with the freetype supplied

in /sw (probably fink supplied). Perhaps it is not configured as a

universal binary.

You can build mpl from svn the way we do when we make a release, which

will automatically fetch and build the dependencies correctly. First

see,

http://matplotlib.sourceforge.net/faq/installing_faq.html#which-python-for-osx

then grab a copy of mpl from svn

http://matplotlib.sourceforge.net/faq/installing_faq.html#install-svn

and cd into the releases/osx directory and follow the instructions in

the README there.

Hi,

I get the same errors when I follow those instructions. I have a very new 17" MacBook Pro running 10.5.7. I’ve installed the Enthought Python Distribution. These commands worked correctly:

unset PKG_CONFIG_PATH
make fetch_deps
cd bdist_mpkg-0.4.3
sudo python setup.py install
cd ..
make dependencies
cd ../..
python setup.py sdist
mv dist/matplotlib-0.98.6svn.tar.gz release/osx/


cd release/osx

I then edit the Makefile and change

MPLVERSION=0.98.5.3

to

MPLVERSION=0.98.6svn

but the next command,

make installers

produces the error:

… < blah blah untarring > …

============================================================================
BUILDING MATPLOTLIB
matplotlib: 0.98.6svn
python: 2.5.4 |EPD_Py25 4.3.0| (r254:67916, May 17 2009,
20:07:12) [GCC 4.0.1 (Apple Computer, Inc. build

                    5370)]
          platform: darwin

REQUIRED DEPENDENCIES
numpy: 1.3.0
freetype2: found, but unknown version (no pkg-config)

OPTIONAL BACKEND DEPENDENCIES

            libpng: found, but unknown version (no pkg-config)
           Tkinter: Tkinter: 67737, Tk: 8.4, Tcl: 8.4
          wxPython: 2.8.7.1
                    * WxAgg extension not required for wxPython >= 2.8


              Gtk+: no
                    * Building for Gtk+ requires pygtk; you must be able
                    * to "import gtk" in your build/install environment
   Mac OS X native: yes


                Qt: no
               Qt4: no
             Cairo: no

OPTIONAL DATE/TIMEZONE DEPENDENCIES
datetime: present, version unknown
dateutil: matplotlib will provide

              pytz: matplotlib will provide

adding pytz

OPTIONAL USETEX DEPENDENCIES
dvipng: no
ghostscript: /bin/sh: gs: command not found
latex: no

[Edit setup.cfg to suppress the above messages]

pymods [‘pylab’]
packages [‘matplotlib’, ‘matplotlib.backends’, ‘matplotlib.projections’, ‘mpl_toolkits’, ‘mpl_toolkits.mplot3d’, ‘mpl_toolkits.axes_grid’, ‘matplotlib.sphinxext’, ‘matplotlib.numerix’, ‘matplotlib.numerix.mlab’, ‘matplotlib.numerix.ma’, ‘matplotlib.numerix.linear_algebra’, ‘matplotlib.numerix.random_array’, ‘matplotlib.numerix.fft’, ‘matplotlib.delaunay’, ‘pytz’, ‘dateutil’, ‘dateutil/zoneinfo’]

running bdist_mpkg
installing to build/bdist.macosx-10.3-fat/mpkg
running build
running build_py
creating build
creating build/lib.macosx-10.3-fat-2.5
copying lib/pylab.py -> build/lib.macosx-10.3-fat-2.5

creating build/lib.macosx-10.3-fat-2.5/matplotlib

… < blah blah, copying > …

creating build/temp.macosx-10.3-fat-2.5/CXX
gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c src/ft2font.cpp -o build/temp.macosx-10.3-fat-2.5/src/ft2font.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c src/mplutils.cpp -o build/temp.macosx-10.3-fat-2.5/src/mplutils.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c CXX/cxx_extensions.cxx -o build/temp.macosx-10.3-fat-2.5/CXX/cxx_extensions.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c CXX/cxxsupport.cxx -o build/temp.macosx-10.3-fat-2.5/CXX/cxxsupport.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c CXX/IndirectPythonInterface.cxx -o build/temp.macosx-10.3-fat-2.5/CXX/IndirectPythonInterface.o

gcc -DNDEBUG -g -O3 -I/tmp/_py/libraries/usr/local/include -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include -DPY_ARRAYAUNIQUE_SYMBOL=MPL_ARRAY_API -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include -I/usr/local/include -I/usr/include -I/usr/X11R6/include -I. -I/Library/Frameworks/Python.framework/Versions/4.3.0/lib/python2.5/site-packages/numpy-1.3.0n1-py2.5-macosx-10.3-fat.egg/numpy/core/include/freetype2 -I/usr/local/include/freetype2 -I/usr/include/freetype2 -I/usr/X11R6/include/freetype2 -I./freetype2 -I/Library/Frameworks/Python.framework/Versions/4.3.0/include/python2.5 -c CXX/cxxextensions.c -o build/temp.macosx-10.3-fat-2.5/CXX/cxxextensions.o

g++ -arch i386 -arch ppc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -g -L/usr/local/lib -L/Library/Frameworks/Python.framework/Versions/4.3.0/lib -bundle -undefined dynamic_lookup -arch ppc -arch i386 -L/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -L/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -L/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7 -Os -arch ppc -arch i386 -I/Users/mglerner/src/matplotlib/release/osx/zlib-1.2.3 -I/Users/mglerner/src/matplotlib/release/osx/libpng-1.2.33 -I/Users/mglerner/src/matplotlib/release/osx/freetype-2.3.7/include build/temp.macosx-10.3-fat-2.5/src/ft2font.o build/temp.macosx-10.3-fat-2.5/src/mplutils.o build/temp.macosx-10.3-fat-2.5/CXX/cxx_extensions.o build/temp.macosx-10.3-fat-2.5/CXX/cxxsupport.o build/temp.macosx-10.3-fat-2.5/CXX/IndirectPythonInterface.o build/temp.macosx-10.3-fat-2.5/CXX/cxxextensions.o -L/usr/local/lib -L/usr/lib -L/usr/X11R6/lib -lfreetype -lz -lstdc++ -lm -o build/lib.macosx-10.3-fat-2.5/matplotlib/ft2font.so

ld warning: in /Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/Python.framework/Versions/4.3.0/lib/libz.dylib, file is not of required architecture
ld warning: in /Developer/SDKs/MacOSX10.4u.sdk/usr/local/lib/libgcc_s.10.4.dylib, missing required architecture ppc in file

ld: in /Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/Python.framework/Versions/4.3.0/lib/libz.1.dylib, file is not of required architecture for architecture ppc

collect2: ld returned 1 exit status

lipo: can’t open input file: /var/folders/mr/mrDdnQgUEQWRcRe-wF1uFE+++TI/-Tmp-//ccvdMAI3.out (No such file or directory)

error: command ‘g++’ failed with exit status 1

make: *** [installers] Error 1

It appears that I have no idea how the OS X build system works, because I’m quite surprised by all of the seeming references to 10.3 and 10.4, given that I’m running 10.5.

I’d be quite happy to provide further information. I’m happy with the stock matplotlib on my system, but I’d like to get this working so I can submit my tiny patch to acorr/xcorr.

Thanks,

-michael

JDH


Enter the BlackBerry Developer Challenge

This is your chance to win up to $100,000 in prizes! For a limited time,

vendors submitting new applications to BlackBerry App World™ will have

the opportunity to enter the BlackBerry Developer Challenge. See full prize

details at: http://p.sf.net/sfu/Challenge


Matplotlib-users mailing list

Matplotlib-users@lists.sourceforge.net

https://lists.sourceforge.net/lists/listinfo/matplotlib-users


Michael Lerner, Ph.D.
IRTA Postdoctoral Fellow
Laboratory of Computational Biology NIH/NHLBI
5635 Fishers Lane, Room T909, MSC 9314

Rockville, MD 20852 (UPS/FedEx/Reality)

Bethesda MD 20892-9314 (USPS)


Michael Lerner, Ph.D.
IRTA Postdoctoral Fellow
Laboratory of Computational Biology NIH/NHLBI
5635 Fishers Lane, Room T909, MSC 9314
Rockville, MD 20852 (UPS/FedEx/Reality)

Bethesda MD 20892-9314 (USPS)