Bus error on import - Mac OS X (10.5.8) Matplotlib 1.0.0

In article <4CFD8253.5060504@...2126...>,
Kaushik Ghose <Kaushik_Ghose@...2126...>
wrote:

Hi Guys,

I did a search on the mailing list but could not come up with a solution, so
I
am crying "Uncle" and writing.

I installed matplotlib 1.0.0 from the package on SF
(http://sourceforge.net/projects/matplotlib/files/matplotlib/matplotlib-1.0/ma
tplotlib-1.0.0-python.org-py2.6-macosx10.4.dmg/download)

I assumed that 10.4 would work on my 10.5 - perhaps that is where I went
wrong?

I installed it and got, satisfactorily:

import matplotlib
matplotlib.__version__
---> '1.0.0'

But when I do

import pylab

I get a bus error that throws me out of ipython.

It should work on Mac OS X 10.4.

A newer version of this binary is available here, which I recommend
instead:
<http://www.astro.washington.edu/users/rowen/python/>

A few things to try:
- Make sure you have Python 2.6 from python.org
- Make sure you have a good numpy build, preferably of 1.5 or 1.5.1
- matplotlib 1.0.0 will crash if it has a problem with the font cache
(though I don't think that is what caused your crash); to fix that
delete the font cache in the ~/.matplotlib directory. That problem
should be fixed in 1.0.1.

-- Russell