Build failure

Hi all,

I cannot build the latest matplotlib from git. The build log is attached.

Nils

build.log.gz (13.3 KB)

It looks like a version mismatch with PyCXX. Was it recently updated or changed? What version of PyCXX do you have? What was the last version of matplotlib that worked for you?

You can force matplotlib to use its local copy of PyCXX by uninstalling PyCXX, or adding the following lines to the top of PyCXX::check in setupext.py:

         self.__class__.found_external = False
         return "Couldn't import. Using local copy."

(But really, we should update setupext so users can specify the local override in setup.cfg).

Mike

···

On 08/30/2013 12:35 PM, Nils Wagner wrote:

Hi all,

I cannot build the latest matplotlib from git. The build log is attached.

Nils

------------------------------------------------------------------------------
Learn the latest--Visual Studio 2012, SharePoint 2013, SQL 2012, more!
Discover the easy way to master current and previous Microsoft technologies
and advance your career. Get an incredible 1,500+ hours of step-by-step
tutorial videos with LearnDevNow. Subscribe today and save!
http://pubads.g.doubleclick.net/gampad/clk?id=58040911&iu=/4140/ostg.clktrk

_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users