basic pgf test fails

I tried the simple example, but all examples I try choke on savefig ('blah.pdf')
This is fedora20 linux, with pretty modern, complete texlive.

I tried rm'ing tex-cache

# -*- coding: utf-8 -*-

import matplotlib as mpl
pgf_with_rc_fonts = {
    "": "serif",
    "font.serif": [], # use latex default serif font
    "font.sans-serif": ["DejaVu Sans"], # use a specific sans-serif font

import matplotlib.pyplot as plt
plt.text(0.5, 3., "serif")
plt.text(0.5, 2., "monospace", family="monospace")
plt.text(2.5, 2., "sans-serif", family="sans-serif")
plt.text(2.5, 1., "comic sans", family="Comic Sans MS")
plt.xlabel(u"µ is not $\\mu$")



/usr/lib64/python2.7/site-packages/matplotlib/ UserWarning:
Found matplotlib configuration in ~/.matplotlib/. To conform with the XDG base
directory standard, this configuration location has been deprecated on Linux,
and the new location is now '/home/nbecker/.config'/matplotlib/. Please move
your configuration there to ensure that matplotlib will continue to find it in
the future.
Traceback (most recent call last):
  File "", line 20, in <module>
  File "/usr/lib64/python2.7/site-packages/matplotlib/", line 1255, in
    fig.tight_layout(pad=pad, h_pad=h_pad, w_pad=w_pad, rect=rect)
  File "/usr/lib64/python2.7/site-packages/matplotlib/", line 1600, in
    renderer = get_renderer(self)
  File "/usr/lib64/python2.7/site-packages/matplotlib/", line
222, in get_renderer
    renderer = canvas.get_renderer()
  File "/usr/lib64/python2.7/site-packages/matplotlib/backends/",
line 925, in get_renderer
    return RendererPgf(self.figure, None, dummy=True)
  File "/usr/lib64/python2.7/site-packages/matplotlib/backends/",
line 409, in __init__
    self.latexManager = LatexManagerFactory.get_latex_manager()
  File "/usr/lib64/python2.7/site-packages/matplotlib/backends/",
line 223, in get_latex_manager
    new_inst = LatexManager()
  File "/usr/lib64/python2.7/site-packages/matplotlib/backends/",
line 305, in __init__
  File "/usr/lib64/python2.7/", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/", line 1308, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory