Backends on Mac OS X

Hello all,

I installed the latest matplot lib last night on my powerbook running Mac OS 10.4. Overall the installation went well, but there were a few hitches. I was able to solve some of the simple problems, but other remain. I wanted to document my experience and also see if anyone has solutions to the other problems.

Here is what I did:

1. Latest Numeric
2. Bob Ippolito's python 2.4.1 (with the Tiger fix)
3. IPython 0.7.0rc1
4. wxPython unicode binary from the wxpython site
5. libpng and freetype from I-Installer
6. CVS matplotlib as of late 12/29/05

I then did

cd matplotlib
python build
sudo python install

I then copied the default matplotlib into the ~/.matplotlib directory and changed the backend.


Out of the box, the WX and TkAgg and CocoaAgg backends worked. I did have problems with WXAgg (which I have solved) and with PS (which I have not solved).


When the WXAgg backend was used I got an exception (MemoryError) when I plotted things. I traced it back to the wxconfig command not being in my PATH variable.

When I moved wxconfig from /usr/local/lib/wxPython-unicode- to /usr/local/bin and rebuilt everything, the WXAgg backend worked fine.

While the wxconfig PATH issue is documented in the source code ( I think) I didn't see anything in the INSTALL file about it. A brief note should be added to the INSTALL file.


When the PS backend is used, the .ps and .eps files produced are somewhat problematic. Here is what I observed:

- PS backend, savefig("")

  The .ps file cannot be opened by preview: "Couldn't convert the PostScript file to a PDF file."

  But running ps2pdf on it produced a pdf file.

- PS backend, savefig("test.eps")

  This does produce a nice eps file that preview can read.

I get the same behavior when using the WXAgg backend and trying to save the figure as a .ps or .eps file.

I know it is a minor issue, but Is there a way to get a raw .ps file that Preview can display?

Thanks in advance