Anyone see this after upgrading?

Just upgraded to 98.4. Can
reproduce this on two XP32 boxes. Any thoughts?

C:\Documents and
Settings\rwagner\Desktop>python

Python 2.5.2 (r252:60911, Feb 21
2008, 13:11:45) [MSC v.1310 32 bit (Intel)] on

win32

Type “help”,
“copyright”, “credits” or “license” for more
information.

from pylab import *

Traceback (most recent call
last):

File
“”, line 1, in

File
“C:\Python25\Lib\site-packages\pylab.py”, line 1, in

from matplotlib.pylab import

···

File
“C:\Python25\Lib\site-packages\matplotlib\pylab.py”, line 253, in
<module

from matplotlib.pyplot
import *

File
“C:\Python25\Lib\site-packages\matplotlib\pyplot.py”, line 75, in
<module

new_figure_manager,
draw_if_interactive, show = pylab_setup()

File
“C:\Python25\Lib\site-packages\matplotlib\backends_init_.py”, line
25,

in pylab_setup

globals(),locals(),[backend_name])

File
“C:\Python25\Lib\site-packages\matplotlib\backends\backend_gtkagg.py”,
li

ne 10, in

from
matplotlib.backends.backend_gtk import gtk, FigureManagerGTK, FigureCan

vasGTK,\

File
“C:\Python25\Lib\site-packages\matplotlib\backends\backend_gtk.py”,
line

11, in

raise ImportError(“Gtk*
backend requires pygtk to be installed.”)

ImportError: Gtk* backend
requires pygtk to be installed.

This is a bug in the win32 installer, which has gtkagg set as the default backend. You can fix this by setting TkAgg in the backend, which is what we should have done in the installer. You need to change the line

backend : GTKAgg

to

backend : TkAgg

in your matplotlibrc config file. Instructions for editing the rc file can be found at http://matplotlib.sourceforge.net/users/customizing.html. You can also read about “what is a backend?” here - http://matplotlib.sourceforge.net/faq/installing_faq.html#id1

We will be putting out new installers that fix this problem ASAP, so those of you who on windows who have not yet installed 98.4 may prefer to wait until we announce the fixed installers are up. This problem does not affect the src tarball or the os x installers.

Sorry for the trouble!
JDH

···

On Wed, Dec 10, 2008 at 5:01 PM, Ryan Wagner <rwagner@…1899…> wrote:

Just upgraded to 98.4. Can
reproduce this on two XP32 boxes. Any thoughts?