another mac os matplotlib question

Hi All,

A few more issues have come up for me with matplotlib in an EPD upgrade.

mac os X 10.6.8, EPD 7.3 (python 2.7, matplotlib 1.1.0)

1) After my code generates a plot (at the moment, not sure if it is a specific plot or all plots), it gives me a long list of the repeated error

Python[10440] <Error>: CGContextClosePath: no current point.

It gives so many, it ruins the point of my interactive analysis session, as it pushes the raw_input queries I am using so far up my terminal screen, it is hard to make progress in the analysis work.

Hoping someone else has seen this and has an idea where to look for the problem (or knows the answer).

2) and 3) Two warnings show up which didn't previously

/Library/Frameworks/Python.framework/Versions/7.3/lib/python2.7/site-packages/matplotlib/ UserWarning: matplotlibrc text.usetex option can not be used unless TeX-3.1415 or later is installed on your system
  'installed on your system') % tex_req)

/Library/Frameworks/Python.framework/Versions/7.3/lib/python2.7/site-packages/matplotlib/ UserWarning: matplotlibrc text.usetex can not be used with *Agg backend unless dvipng-1.5 or later is installed on your system
  warnings.warn( 'matplotlibrc text.usetex can not be used with *Agg '

I tried looking for where matplotlib points to the TeX distribution. I have used TeXShop for years and never had a problem. Also - previously on EPD 6.3, I did not get this warning, and all my fonts rendered correctly. I should say, it appears they still render correctly, but if I can point it to my TeXShop build instead of texmf that would be nice.

I have my backend set to MacOSX, so I don't understand why I get the second error message.

I tried reverting back to my 6.3 build, but that is now buggy and doesn't render fonts correctly. It is having trouble with the ticks and ticklabels, and gives a long list of errors. At the moment, if I can get the 7.3 build working, I can happily ignore my issues in 6.3.