All kinds of issues inslalling basemap under Ubuntu 8.10 64bit [SEC=UNCLASSIFIED]

Greetings…

I have been using basemap extensively to do presentation graphics under quite a wide variety of platforms but I got a new 64bit dual core laptop recently and have been having all kinds of problems installing it…

I am using (K)ubuntu 8.10 and have tried to install it two ways… This is a 64bit system

(1) using the pre-compiles libgeos 3.0.0:

this is installed using the libgeos-dev package under ubuntu

The package (seems) to install ok

I then grab the latest source and do the usual python setup.py build jobbo

and get a massive raft of errors eg:

src/_proj.c:2353: error: ‘__pyx_kp_4’ undeclared here (not in a function)
src/_proj.c:2353: warning: excess elements in struct initializer
src/_proj.c:2353: warning: (near initialization for ‘__pyx_string_tab[19]’)
src/_proj.c:2353: warning: excess elements in struct initializer
src/_proj.c:2353: warning: (near initialization for ‘__pyx_string_tab[19]’)
src/_proj.c:2353: warning: excess elements in struct initializer

src/_proj.c:3155: error: expected ‘)’ before ‘’ token
src/_proj.c:3170: error: expected ‘)’ before ‘
’ token
src/_proj.c:3185: error: expected ‘)’ before ‘’ token
src/_proj.c:3200: error: expected ‘)’ before ‘
’ token
src/_proj.c:3215: error: expected ‘)’ before ‘’ token
src/_proj.c:3230: error: expected ‘)’ before ‘
’ token
error: Command “gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -Isrc -I/usr/lib/python2.5/site-packages/numpy/core/include -I/usr/include/python2.5 -c src/_proj.c -o build/temp.linux-x86_64-2.5/src/_proj.o” failed with exit status 1

(2) building libgeos from source…

I get the same error for 2.2.3 (a version I have had no problems compiling on centos5 64bit machines in the past) and 3.0.0

make[3]: Entering directory /home/scollis/geos-3.0.0/source/index/quadtree' if /bin/bash ../../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../../../source/headers -I../../../source/headers/geos -I../../../source/headers -g -O2 -DGEOS_INLINE -Wall -ansi -pedantic -Wno-long-long -MT DoubleBits.lo -MD -MP -MF ".deps/DoubleBits.Tpo" -c -o DoubleBits.lo DoubleBits.cpp; \ then mv -f ".deps/DoubleBits.Tpo" ".deps/DoubleBits.Plo"; else rm -f ".deps/DoubleBits.Tpo"; exit 1; fi g++ -DHAVE_CONFIG_H -I. -I. -I../../../source/headers -I../../../source/headers/geos -I../../../source/headers -g -O2 -DGEOS_INLINE -Wall -ansi -pedantic -Wno-long-long -MT DoubleBits.lo -MD -MP -MF .deps/DoubleBits.Tpo -c DoubleBits.cpp -fPIC -DPIC -o .libs/DoubleBits.o DoubleBits.cpp: In static member function 'static double geos::index::quadtree::DoubleBits::powerOf2(int)': DoubleBits.cpp:51: error: 'memcpy' was not declared in this scope DoubleBits.cpp: In constructor 'geos::index::quadtree::DoubleBits::DoubleBits(double)': DoubleBits.cpp:94: error: 'memcpy' was not declared in this scope make[3]: *** [DoubleBits.lo] Error 1 make[3]: Leaving directory/home/scollis/geos-3.0.0/source/index/quadtree’
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory /home/scollis/geos-3.0.0/source/index' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory/home/scollis/geos-3.0.0/source’
make: *** [all-recursive] Error 1

ANY help very very very welcome! I am some what at a loss as I have managed to compile both libgeos and basemap under much more “user unfriendly” distros before…

Dr Scott Collis

Postdoctoral Researcher

Centre for Australian Weather and Climate Research (CAWCR)

Atmosphere and Land Observation and Assessment Group

Australian Bureau of Meteorology Room 9.57 Level 9 700 Collins Street Docklands 3008

Office: (03) 9669 4766

MB: 0412177550

http://www.bom.gov.au/bmrc/wefor/staff/scollis/

Scott Collis wrote:

Greetings...
I have been using basemap extensively to do presentation graphics under quite a wide variety of platforms but I got a new 64bit dual core laptop recently and have been having all kinds of problems installing it...
I am using (K)ubuntu 8.10 and have tried to install it two ways... This is a 64bit system
(1) using the pre-compiles libgeos 3.0.0:
this is installed using the libgeos-dev package under ubuntu
The package (seems) to install ok
I then grab the latest source and do the usual python setup.py build jobbo
and get a massive raft of errors eg:
......
src/_proj.c:2353: error: ‘__pyx_kp_4’ undeclared here (not in a function)
src/_proj.c:2353: warning: excess elements in struct initializer
src/_proj.c:2353: warning: (near initialization for ‘__pyx_string_tab[19]’)
src/_proj.c:2353: warning: excess elements in struct initializer
src/_proj.c:2353: warning: (near initialization for ‘__pyx_string_tab[19]’)
src/_proj.c:2353: warning: excess elements in struct initializer
..
src/_proj.c:3155: error: expected ‘)’ before ‘*’ token
src/_proj.c:3170: error: expected ‘)’ before ‘*’ token
src/_proj.c:3185: error: expected ‘)’ before ‘*’ token
src/_proj.c:3200: error: expected ‘)’ before ‘*’ token
src/_proj.c:3215: error: expected ‘)’ before ‘*’ token
src/_proj.c:3230: error: expected ‘)’ before ‘*’ token
error: Command "gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -Isrc -I/usr/lib/python2.5/site-packages/numpy/core/include -I/usr/include/python2.5 -c src/_proj.c -o build/temp.linux-x86_64-2.5/src/_proj.o" failed with exit status 1
(2) building libgeos from source...
I get the same error for 2.2.3 (a version I have had no problems compiling on centos5 64bit machines in the past) and 3.0.0
make[3]: Entering directory `/home/scollis/geos-3.0.0/source/index/quadtree'
if /bin/bash ../../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../../../source/headers -I../../../source/headers/geos -I../../../source/headers -g -O2 -DGEOS_INLINE -Wall -ansi -pedantic -Wno-long-long -MT DoubleBits.lo -MD -MP -MF ".deps/DoubleBits.Tpo" -c -o DoubleBits.lo DoubleBits.cpp; \
then mv -f ".deps/DoubleBits.Tpo" ".deps/DoubleBits.Plo"; else rm -f ".deps/DoubleBits.Tpo"; exit 1; fi
g++ -DHAVE_CONFIG_H -I. -I. -I../../../source/headers -I../../../source/headers/geos -I../../../source/headers -g -O2 -DGEOS_INLINE -Wall -ansi -pedantic -Wno-long-long -MT DoubleBits.lo -MD -MP -MF .deps/DoubleBits.Tpo -c DoubleBits.cpp -fPIC -DPIC -o .libs/DoubleBits.o
DoubleBits.cpp: In static member function 'static double geos::index::quadtree::DoubleBits::powerOf2(int)':
DoubleBits.cpp:51: error: 'memcpy' was not declared in this scope
DoubleBits.cpp: In constructor 'geos::index::quadtree::DoubleBits::DoubleBits(double)':
DoubleBits.cpp:94: error: 'memcpy' was not declared in this scope
make[3]: *** [DoubleBits.lo] Error 1
make[3]: Leaving directory `/home/scollis/geos-3.0.0/source/index/quadtree'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/scollis/geos-3.0.0/source/index'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/scollis/geos-3.0.0/source'
make: *** [all-recursive] Error 1
ANY help very very very welcome! I am some what at a loss as I have managed to compile both libgeos and basemap under much more "user unfriendly" distros before...
Dr Scott Collis
Postdoctoral Researcher
Centre for Australian Weather and Climate Research (CAWCR)
Atmosphere and Land Observation and Assessment Group
Australian Bureau of Meteorology Room 9.57 Level 9 700 Collins Street Docklands 3008
Office: (03) 9669 4766
MB: 0412177550
http://www.bom.gov.au/bmrc/wefor/staff/scollis/

Scott: I don't think the error compiling _proj.c has anything to do with libgeos, my guess is it can't find Python.h - perhaps you have to install a python-dev package?

The geos compile error (can't find "memcpy") suggest that all your C header files are not found (I think that function is in "string.h"), which suggests that you haven't installed all the necessary gcc packages.

-Jeff

Scott Collis wrote:

Greetings...
I have been using basemap extensively to do presentation graphics under quite a wide variety of platforms but I got a new 64bit dual core laptop recently and have been having all kinds of problems installing it...
I am using (K)ubuntu 8.10 and have tried to install it two ways... This is a 64bit system
(1) using the pre-compiles libgeos 3.0.0:
this is installed using the libgeos-dev package under ubuntu
The package (seems) to install ok
I then grab the latest source and do the usual python setup.py build jobbo
and get a massive raft of errors eg:
......
src/_proj.c:2353: error: ‘__pyx_kp_4’ undeclared here (not in a function)
src/_proj.c:2353: warning: excess elements in struct initializer
src/_proj.c:2353: warning: (near initialization for ‘__pyx_string_tab[19]’)
src/_proj.c:2353: warning: excess elements in struct initializer
src/_proj.c:2353: warning: (near initialization for ‘__pyx_string_tab[19]’)
src/_proj.c:2353: warning: excess elements in struct initializer
..
src/_proj.c:3155: error: expected ‘)’ before ‘*’ token
src/_proj.c:3170: error: expected ‘)’ before ‘*’ token
src/_proj.c:3185: error: expected ‘)’ before ‘*’ token
src/_proj.c:3200: error: expected ‘)’ before ‘*’ token
src/_proj.c:3215: error: expected ‘)’ before ‘*’ token
src/_proj.c:3230: error: expected ‘)’ before ‘*’ token
error: Command "gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -Isrc -I/usr/lib/python2.5/site-packages/numpy/core/include -I/usr/include/python2.5 -c src/_proj.c -o build/temp.linux-x86_64-2.5/src/_proj.o" failed with exit status 1
(2) building libgeos from source...
I get the same error for 2.2.3 (a version I have had no problems compiling on centos5 64bit machines in the past) and 3.0.0
make[3]: Entering directory `/home/scollis/geos-3.0.0/source/index/quadtree'
if /bin/bash ../../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../../../source/headers -I../../../source/headers/geos -I../../../source/headers -g -O2 -DGEOS_INLINE -Wall -ansi -pedantic -Wno-long-long -MT DoubleBits.lo -MD -MP -MF ".deps/DoubleBits.Tpo" -c -o DoubleBits.lo DoubleBits.cpp; \
then mv -f ".deps/DoubleBits.Tpo" ".deps/DoubleBits.Plo"; else rm -f ".deps/DoubleBits.Tpo"; exit 1; fi
g++ -DHAVE_CONFIG_H -I. -I. -I../../../source/headers -I../../../source/headers/geos -I../../../source/headers -g -O2 -DGEOS_INLINE -Wall -ansi -pedantic -Wno-long-long -MT DoubleBits.lo -MD -MP -MF .deps/DoubleBits.Tpo -c DoubleBits.cpp -fPIC -DPIC -o .libs/DoubleBits.o
DoubleBits.cpp: In static member function 'static double geos::index::quadtree::DoubleBits::powerOf2(int)':
DoubleBits.cpp:51: error: 'memcpy' was not declared in this scope
DoubleBits.cpp: In constructor 'geos::index::quadtree::DoubleBits::DoubleBits(double)':
DoubleBits.cpp:94: error: 'memcpy' was not declared in this scope
make[3]: *** [DoubleBits.lo] Error 1
make[3]: Leaving directory `/home/scollis/geos-3.0.0/source/index/quadtree'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/scollis/geos-3.0.0/source/index'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/scollis/geos-3.0.0/source'
make: *** [all-recursive] Error 1
ANY help very very very welcome! I am some what at a loss as I have managed to compile both libgeos and basemap under much more "user unfriendly" distros before...

Scott: Could you try this modification to DoubleBits.cpp and let me know if it fixes the geos-2.2.3 compilation? I think you must be using gcc 4.3, which is much pickier than earlier versions about such things.

Index: source/index/quadtree/DoubleBits.cpp

···

===================================================================
--- source/index/quadtree/DoubleBits.cpp (revision 6729)
+++ source/index/quadtree/DoubleBits.cpp (working copy)
@@ -15,6 +15,7 @@

#include <geos/indexQuadtree.h>
#include <geos/util.h>
+#include <string>
#include <cstring>

Thanks,

-Jeff

Dr Scott Collis
Postdoctoral Researcher
Centre for Australian Weather and Climate Research (CAWCR)
Atmosphere and Land Observation and Assessment Group
Australian Bureau of Meteorology Room 9.57 Level 9 700 Collins Street Docklands 3008
Office: (03) 9669 4766
MB: 0412177550
http://www.bom.gov.au/bmrc/wefor/staff/scollis/
------------------------------------------------------------------------

------------------------------------------------------------------------------
Check out the new SourceForge.net Marketplace.
It is the best place to buy or sell services for
just about anything Open Source.
http://p.sf.net/sfu/Xq1LFB
------------------------------------------------------------------------

_______________________________________________
Matplotlib-users mailing list
Matplotlib-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-users
  
--
Jeffrey S. Whitaker Phone : (303)497-6313
Meteorologist FAX : (303)497-6449
NOAA/OAR/PSD R/PSD1 Email : Jeffrey.S.Whitaker@...259...
325 Broadway Office : Skaggs Research Cntr 1D-113
Boulder, CO, USA 80303-3328 Web : http://tinyurl.com/5telg