agg in matplotlib

Hi John, I dont know whether you are the person to write

    > to, but I simply try. I am trying to install matplotlib
    > on:

    > SunOS st13 5.8 Generic_108528-21 sun4u sparc
    > SUNW,Sun-Blade-1500

    > with gcc 3.3.2.

    > In principle it works, and with the PS-backend it gives
    > results. I would like to install the agg-backend, but did
    > not manage to do so. I just installed the
    > freetype2-library, and to include it at its position I
    > changed the code in '', module
    > 'add_agg_flags(module)', line 94 to;

    > module.include_dirs.extend(
    > ['/ecfsoft/pyraf1.1/include/freetype2',] )
    > module.include_dirs.extend( ['/ecfsoft/pyraf1.1/include',]
    > )

    > i am still not at home, and I get the error messages:

    > Text relocation remains referenced against symbol offset
    > in file <unknown> 0x40
    > /ecfsoft/pyraf1.1/lib/libz.a(deflate.o) <unknown> 0x4c
    > /ecfsoft/pyraf1.1/lib/libz.a(deflate.o) <unknown> 0x58
    > /ecfsoft/pyraf1.1/lib/libz.a(deflate.o)

    > It seems not to include the libz correctly, but this
    > library exists also at '/ecfsoft/pyraf1.1/include' and
    > '/ecfsoft/pyraf1.1/lib'.

    > What can I do?

    > Cheers and thanks in advance, Martin

    > P.S.: Please forward this mail to the appropriate person,
    > or give me its email address

Hi Martin,

We are very interested in getting a build that works properly under
Solaris so thanks for writing and offering to be the crash test dummy.
I CCd this email to the matplotlib development list since some folks
there know a bit about solaris. You may want to consider joining the
user or development mailing list for future questions -

I suggest you try working with the latest matplotlib snapshot
which has a somewhat improved (it also includes basic
image support with the imshow command). Usually to get freetype you
need the dir that includes ft2build.h and the freetype2 include dir in
your include_path.

But it looks like you are getting a link error rather than an include
error. I just posted

"Text relocation remains referenced against symbol offset"

into google and got this result
That post suggests you need the linker flags -Wl,-G

Search google groups with the same error message and you'll get lots
of threads that look helpful.

When you get this working if you can post a modified as
well as any additional dependencies and build instructions, that would
be great.