3d plotting question

Forwarding this to the list....

I'm curious if you run into another problem I recently reported. Can you do, e.g.:

import copy
import pylab as P
import matplotlib.axes3d as P3
def test() :
     [X,Y] = P.meshgrid(P.linspace(-3,3,7),P.linspace(-3,3,7))
     Z = copy.deepcopy(X)
     Z1 = copy.deepcopy(X)
     for i in xrange(len(X)) :
         for j in xrange(len(X[0])) :
             Z[i][j] = X[i][j]*Y[i][j]
             Z1[i][j] = X[i][j]*Y[i][j] - 5
     P.close('all')
     fig = P.figure()
     ax = P3.Axes3D(fig)
     ax.plot3d(ravel(X),ravel(Y),ravel(Z),'r.-')

or do you instead get an error in matplotlib's axes.py, complaining about self.autoscale_view and a scalex parameter? For more on the hack I made to axes.py file which then allowed me to use plot3d, see http://www.mail-archive.com/matplotlib-users@lists.sourceforge.net/msg03041.html.

Thanks for providing more info.

--b

···

Begin forwarded message:

From: "Richard Brown" <rgbrown@...287...>
Date: April 11, 2007 8:41:37 PM PDT
To: "belinda thom" <bthom@...1382...>
Subject: Re: [Matplotlib-users] 3d plotting question

On 12/04/07, belinda thom <bthom@...1382...> wrote:

I also seem to have some other 3D plotting problems. Again, following
some of the demo/test advice in the cookbook, I tried things like

   import pylab as p
   import matplotlib.axes3d as P3
   P3.test_surface()

I too just encountered the same problem - what is the last version of
mpl for which doing this worked? (I'm using 0.9 revision 3131)

--
Richard Brown
Ph.D. Candidate
Dept. of Mechanical Engineering
University of Canterbury, NZ